JQuery - Conflicto entre versiones diferentes de jquery

   
Vista:

Conflicto entre versiones diferentes de jquery

Publicado por sam (31 intervenciones) el 16/09/2013 23:50:55
Hola buenas, verán tengo un pequeño problema de incompatibilidad de 2 versiones distintas de jquery.

He leído en este sentido, pero no me termino de aclarar con mi caso en concreto.

Lo que me pasa es que tengo un jquery que me permite hacer un scrollbar personalizado tanto en forma como color etc.

Y la otra versión de jquery me permite hacer un menú para mi web estilo dock de mac.

Pero cuando pongo las dos aplicaciones juntas cada una con su versión de jquery , una de ellas no me va.

He probado a ponerlas en la misma versión las dos pero no funciona.

Ni tan siquiera en la ultima versión estable.

Resumiendo funcionan ambas pero cada una en su versión en la cual se concibieron.

Ahora bien, he leído que mediante noConflict, esto tendría arreglo.

Pero no se como hacerlo.

Si alguien pudiera echarme una mano se lo agradecería enormemente:

Para el menu dock estoy poniendo:

jquery.js
interface_dock.js


y para el scroll:

jquery-1.9.1.min.js
jquery.mCustomScrollbar.concat.min.js

Saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Conflicto entre versiones diferentes de jquery

Publicado por xve (557 intervenciones) el 17/09/2013 08:45:05
Hola Sam, tu archivo jquery.js, que versión de jquery es?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Conflicto entre versiones diferentes de jquery

Publicado por Sam (31 intervenciones) el 17/09/2013 09:50:56
Hola xve, pues abriendo el archivo jquery.js, dentro pone:

jQuery 1.1.2 bla bla bla 2007 etc


Espero que sirva. Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Conflicto entre versiones diferentes de jquery

Publicado por xve (557 intervenciones) el 17/09/2013 16:18:06
Hola Sam, yo lo que buscaría es la versión actualizada del interface_dock.js para que funcione con jquery 1.9.

La versión 1.1 es muy antigua...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Conflicto entre versiones diferentes de jquery

Publicado por Sam (31 intervenciones) el 17/09/2013 22:39:23
Xve, lo he logrado al fin!!! Ha sido pasando a la version 1.6.1 la mas antigua que era 1.1.2 por que el resto de versiones no me iban las mas modernas como la 2.0.3


Pero ahora tengo otro problema de novato que le estoy dando caña y no me rula.
Es lo siguiente:

Tengo esta funcion que me aplica unos estilos css a mi scrollbar a un div llamado "contenido_somos" mediante:

1
2
3
4
5
6
7
8
9
10
11
<script>
            (function($){
                $(window).load(function(){
                    $(".contenido_somos").mCustomScrollbar({
                        scrollButtons:{
                            enable:true
                        }
                    });
                });
            })(jQuery);
        </script>

Y esto funciona muy bien, pero quiero aplicárselos también a la vez a un div cuya clase se llama "contenido_contacto" en donde tengo un segundo scrollbar y no consigo que me vaya en los dos lados a la vez .

He puesto esto:

1
2
3
4
5
6
7
8
9
10
11
<script>
            (function($){
                $(window).load(function(){
                    $(".contenido_contacto").mCustomScrollbar({
                        scrollButtons:{
                            enable:true
                        }
                    });
                });
            })(jQuery);
        </script>

Si me pudieras ayudar te estaría muy agradecido.

Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar