Java - Instalar j2sdk

   
Vista:

Instalar j2sdk

Publicado por andres (2 intervenciones) el 13/07/2010 00:38:16
Hola gente del foro, mi problema es el siguiente: he instalado en mi computador con windows vista home basic jdk 6, pero cuando voy a la carpeta JAVA, sólo me aparecen dos carpetas que se llaman: jdk1.6.0_21 y jre6 y necesito instalar el j2sdk 1_4_2_0 (¿viene en el programa que instalé?) por si la las dudad traté descargarlo desde la página de java, pero me aparece lo siguiente:

On October 30, 2008 J2SE 1.4.2 reached the end of its service life (EOSL). Customers interested in learning more about Sun's Java Technology Support and EOL policy »Read More

On Solaris 9 and Solaris 10 Java SE 1.4.2 JDK packages for Solaris will continue to be available for Sun contract customers. For information on how to download the JDK for use on Solaris 9 and Solaris 10 please see SunSolve Document - Infodoc ref: 255468:

Customers interested in continuing to receive critical fixes, are encouraged to consider the following options:

Migrate to Java SE for Business 1.4.2 »Read More
Migrate to the latest Java SE release »Read More
For developer needs, all products that have completed the EOL transition period, including the last Java SE release of 1.4.2, have been moved to the Archive area.

Sun Community Source License

¿Cómo puedo obtener el programa? ¿Existe alguna nueva versión? ¿Qué hago?

Desde ya gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Instalar j2sdk

Publicado por James (207 intervenciones) el 13/07/2010 23:55:07
Para que necesitas JAVA especificamente el sdk1.4, te comento que eso esta realmente desactualizado, la version actual es la 6.20 por lo que veo ya lo instalaste te comento que java a partir de las version 1.5 dio un cambio drastico incluso en la nomenclatura de version con lo cual se elimino el 2 que antes se incluia por ejemplo antes era J2SE ahora JSE antes J2SDK ahora simplemente JDK la version que tienes es actual no te preocupes todo deberia marchar bien, Suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Instalar j2sdk

Publicado por andres (2 intervenciones) el 15/07/2010 02:56:46
Gracias por responder. Ahora tengo otro problema, lo que pasa es que he creado un archivo .JAVA (MiPrimeraClase.java) y lo he buscado en el cmd (símbolo del sistema) hasta ahí todo bien, pero cuando escribo el "javac MiPrimeraClase.java" me da un error que dice acceso denegado, y crea un archivo que se llama "MiPrimeraClase.java.bak", ¿Cuál puede ser el problema?

Datos adionales.

Entro al cmd y luego escribo: 1) cd \
2) dir (aquí aparece el nombre del arcivo)

3) cd test (EN UN TUTORIAL DECIA QUE HABÍA QUE PONER ESTO, PERO NO SALE NADA)

4) LUEGO ESCRIBO javac MIPrimeraClase.java y me lanza el error que mencioné anteriormente y crea ese archivo java.bak

¿Qué puede ser? ¿Qué hice mal? ¿Me falta algo?


El archivo .java lo creé con edit plus.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Instalar j2sdk

Publicado por James (2 intervenciones) el 15/07/2010 09:04:25
Saludos andres, tu problema puede deberse a varias causas por lo que espones usas windows puede ser que tu calse este en un directorio sin permisos o puede ser que instalaste JAVA con un usuario administrador o podria deberse a algun tipo de control de dominio, o podria ser que se te haya instalado mal el JDK, si empiezas con JAVA te recomendaria usar un IDE podria ser Eclipse o Netbeans personalmente te recomendaria el ultimo, la verdad es bueno saber hacerlo a mano pero para empezar mejor usa un IDE, te recominedo postees tu duda en un debate aca

http://grupos.emagister.com/foro_java/6709

de esa forma talves te podria ayudar mejor, Suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Instalar j2sdk

Publicado por PEPITOO (1 intervención) el 05/08/2011 00:33:40
estas cagado mi amogoooo..

tienes que usar alguna version de linux e instalar ahi netbeans o eclipse y podras programar libremente sin ninguna dificultad
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar