Java - JDK 1.4 y 1.5

   
Vista:

JDK 1.4 y 1.5

Publicado por omarete (1 intervención) el 26/09/2011 17:44:56
Hola, quisiera saber por qué cuando descargo el JDK 1.4 y compilo un archivo y creo el jar (todo desde linea de comandos) en el archivo "manifest" del .jar me dice que fue creado con el jdk 1.5 ?

Sucede que el .java debe ser compilado con la version 1.4 porque así me lo pidieron en mi trabajo pero no pude hacerlo desde netbeans dado que no soporta versiones menores a 1.6 del JDK.

Espero que puedan responder mi pregunta, gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

JDK 1.4 y 1.5

Publicado por Tom (907 intervenciones) el 27/09/2011 09:38:09
En Netbeans, en las propiedades del proyecto puedes indicar el "source level" para compilar. Que yo sepa, puedes poner 1.4 sin problemas aunque uses el jdk 6.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar