Java - Escribir una cadena de x longitud y que guarde los comodines en un vector

   
Vista:

Escribir una cadena de x longitud y que guarde los comodines en un vector

Publicado por Alejandron (1 intervención) el 19/10/2014 01:35:55
Cordial Saludo.

Necesito Una Colaboración para un ejercicio pero en pseudocodigo el cual dice así:

escribir una cadena de x longitud y que guarde los comodines en un vector y al final los imprima

La verdad no se muy bien la programacion

Agradezco De Antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de milton

Escribir una cadena de x longitud y que guarde los comodines en un vector

Publicado por milton mltn_1ero_vee@hotmail.com (1 intervención) el 19/10/2014 19:23:53
hola, solo conozco un programa de pseudocodigo que se llama pseint:

aqui esta el codigo:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
Proceso Comodines
	//solicitamos ingresar una cadena de texto.
	Escribir "INGRESE UNA CADENA";
	//leemos y guardamos la cadena en la variable cadena.
	Leer cadena;
 
	//inicializamos la cadena de comodines con los comodines.
	cadena_comodines = "^$?~#@|[]()\";
 
	//creamos un contador para saber el largo del vector con los comodines que crearemos.
	contador <- 0;
 
	//creamos 2 ciclos para comparar cada caracter de la cadena ingresada con cada caracter de
	//la cadena de comodines, si son iguales, le agrega 1 al contador.
	Para i<-1 Hasta Longitud(cadena) Con Paso 1 Hacer
		s1 <- Subcadena(cadena,i,i);
		Para j<-1 Hasta Longitud(cadena_comodines) Con Paso 1 Hacer
			s2 <- Subcadena(cadena_comodines,j,j);
			Si s1 = s2 Entonces
				contador <- contador + 1;
			Fin Si
		Fin Para
	Fin Para
 
	//creamos un vector o dimension con el largo del contador.
	Dimension vector_comodines(contador);
	//reseteamos el contador, pero esta vez en 1 para que sea un indice para llenar el vector comodines.
	contador <- 1;
 
	//creamos de nuevos dos ciclos, esta vez para llenar el vector con los datos.
	//si son iguales, ademas de llenar la matriz le suma 1 al contador.
	Para i<-1 Hasta Longitud(cadena) Con Paso 1 Hacer
		s1 <- Subcadena(cadena,i,i);
		Para j<-1 Hasta Longitud(cadena_comodines) Con Paso 1 Hacer
			s2 <- Subcadena(cadena_comodines,j,j);
			Si s1 = s2 Entonces
				vector_comodines(contador)<-s2;
				contador <- contador + 1;
			Fin Si
		Fin Para
	Fin Para
 
	//hacemos un ciclo para mostrar cada elemento del vector comodines.
	//(desde 1 hasta la longitud del vector comodines).
	// se le resta 1 al contador por que como se inicio en 1 le va a sobrar 1.
	Para i<-1 Hasta contador-1 Con Paso 1 Hacer
		Escribir "COMODIN ",i,": ",vector_comodines(i);
	Fin Para
 
	//SUERTE!!!
 
FinProceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar