Java - duda codigo para ejecutar en DFD

   
Vista:
Imágen de perfil de Juan

duda codigo para ejecutar en DFD

Publicado por Juan (3 intervenciones) el 19/04/2015 01:27:44
Enunciado: Desarrollar un algoritmo que lea un número N entero positivo de
cualquier número de dígitos, calcule la suma de sus dígitos y que
imprima en pantalla el número leído y la suma de sus dígitos. Se
requiere que en el desarrollo utilice la Estructura Cíclica Mientras.
Ejemplo:
N= 3567
SUMA= 21



Este es el pseudocodigo que realize pero no he podido implementarlo en el programa DFD, se le agradeceria la ayuda.
Proceso sumaDigitos
Definir N,S Como Entero
Repetir
Imprimir "Ingrese un número entero positivo"
leer N
Mientras Que N<1
Imprimir sin saltar "Número = ",N," Suma = "
S=0
Mientras N>9
S=S+(N mod 10)
N=N/10
FinMientras
Imprimir S+N
FinProceso
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder