JavaScript - Problemas con Internet Explorer

   
Vista:

Problemas con Internet Explorer

Publicado por Eduardo Gonzalez (2 intervenciones) el 07/08/2008 01:20:12
Hola, estoy haciendo una aplicación web, estoy utilizando Ajax, y parte de esa aplicación es el poder hacer un upload de imágenes al servidor estilo Ajax, bueno, eso lo tengo casi listo y en Firefox funciona de maravilla, también en Opera, pero en Internet Explorer 7 (internet explorer 8 emulando el 7) me da un error curioso,

así funciona el programa, tengo un iframe en donde un formulario apunta con el action, mediante el httprequest (como todo ajax) hago submit al formulario y espero, capturo el evento onload del iframe para ver cuando finalizo de cargarse, al hacerlo simplemente en un div inserto un thumbnail de la imagen que subí al servidor. pues lo raro es que con IE 7 me hace una llamada a la función de PHP 2 veces, la imagen se sube 2 veces al servidor, y se hacen 2 thumbnails, eso ocurre solo la primera vez que subo la imagen (con las otras imágenes que subo no ocurre) y solo ocurre cuando después de subirla con el input file, le doy click al div que contiene las imágenes ... Este div NO tiene NINGÚN evento asociado...... a mi me parece muy pero muy extraño y no se como solucionarlo, espero que me puedan ayudar. Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas con Internet Explorer

Publicado por Eduardo Gonzalez (2 intervenciones) el 07/08/2008 01:21:23
Bueno, solo para aclarar, ya lo probe con IE 7 (no la emulacion) y pasa los mismo, con IE 6 no tengo ningun problema, tampoco con la ultima version de Opera
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar