Linux - No funciona el teclado en Slackware 14.1.

   
Vista:

No funciona el teclado en Slackware 14.1.

Publicado por Miguel (5 intervenciones) el 09/04/2014 15:45:42
Hola a todos.

Acabo de instalar Slackware 14.1 en una computadora de 32 bits, en un lvm cifrado, para ello seguí los siguientes pasos:

Inserto un pendrive con Slackware 14.1 mediante unetbootin.

Elegí el mapa de teclado en español.

Ingreso cómo root y ejecuto los siguientes comandos:

fdisk /dev/sda

borro las 2 particiones anteriores, creo dos particiones primarias nuevas, /dev/sda1 de 7GB y /dev/sda2 de 450GB aproximandamente y hago bootable a /dev/sda1.

cryptsetup -s 256 -y luksFormat /dev/sda2

tecleo YES e introduzco la contraseña de cifrado.

cryptsetup luksOpen /dev/sda2 slacwarecrypt

Introduzco la contraseña para descifrar y contiuo con el proceso de instalación.

pvcreate /dev/mapper/slacwarecrypt

vgcreate slacwarevg /dev/mapper/slacwarecrypt

lvcreate -L 20G -n swap slacwarevg

lvcreate -l 100%FREE -n root slackwarevg

vgscan

vgscan --mknodes

vgchange -a y

mkswap /dev/slackwarevg/root

setup

Entonces activo swap

Elijo /dev/slackwarevg/root cómo partición / con ext4 y /dev/sda1 cómo partición /boot con ext4.

Después instalo todos los programas( full ).

Cuando termina elijo instalar lilo en el MBR modo de vga estándar, configuro la red, configuro la contraseña de root y salgo de setup.

Después hago:

chroot /mnt

mkinitrd -c -k 3.10.17-smp -m ext4 -f ext4 -l es -r /dev/slackwarevg/root -C /dev/sda2 -L

Después:

vi /etc/lilo.conf

Modifico image=vmlinuz a image=/boot/vmlinuz-generic-smp-3.10.17-smp y añado initrd=/boot/initrd.gz y etncoes ejecuto:

lilo

y despues reinicio con ctr-al-spr

Arranca lilo cargo el kernel, todo va bien, el teclado usb funciona perfectamente durante lilo, puedo elegir opciones con las fechas del teclado, todo funciona bien, pero cuando carga el kernel y aparece el prompt que indica que introduzca la contraseña para descifrar el lvm cifrado, no funciona el teclado, ni siquiera se encienden ninguno de los 3 leds y si conecto el ratón, ni siquiera se enciende el láser, es decir que aparece el prompt pero al no funcionar el teclado( que es un teclado usb y tengo activado en la bios la opción usb keyboard legacy enable ) no puedo introducir la contraeña, pero el kernel sigue esperándola y el cursor parpadea esperándo la contraseña, por que puede ser, es que hace falta cargar algún módulo para que reconozca el teclado usb, pero tampoco reconoce el teclado PS/2.

Mi teclado usb es logitech KPG66B47 M/N:Y-BP62a P/N:820-000235 PID:SY002UK Ultra Flat Keyboard.
Os adjunto lilo.conf:

LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/sda

#compact # faster, but won't work on all systems.

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used. We don't specify it here, as there's just one column.
bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# Normal VGA console
vga = normal
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask
# VESA framebuffer console @ 1024x768x64k
#vga=791
# VESA framebuffer console @ 1024x768x32k
#vga=790
# VESA framebuffer console @ 1024x768x256
#vga=773
# VESA framebuffer console @ 800x600x64k
#vga=788
# VESA framebuffer console @ 800x600x32k
#vga=787
# VESA framebuffer console @ 800x600x256
#vga=771
# VESA framebuffer console @ 640x480x64k
#vga=785
# VESA framebuffer console @ 640x480x32k
#vga=784
# VESA framebuffer console @ 640x480x256
#vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz-generic-smp-3.10.17-smp
initrd = /boot/initrd.gz
root = /dev/slacwarevg/root
label = Slackware
read-only
# Linux bootable partition config ends

Esta es la información del procesado de cat /proc/cpuinfo:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Pentium(R) Dual-Core CPU E5700 @ 3.00GHz
stepping : 10
cpu MHz : 1200.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm dts tpr_shadow vnmi flexpriority
bogomips : 5999.99
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Pentium(R) Dual-Core CPU E5700 @ 3.00GHz
stepping : 10
cpu MHz : 1200.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm dts tpr_shadow vnmi flexpriority
bogomips : 5999.91
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Mi placa base es gigabyte GA-G41MT-S2.

Si es necesaria alguna información más decídmelo y os la proporcionaré.

Saludos a todos y gracias de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

No funciona el teclado en Slackware 14.1.

Publicado por Tom (344 intervenciones) el 09/04/2014 16:29:12
Hay bastantes bugs reportados, con una búsqueda en google se encuentra bastante info.

Seguramente te valga esto:

http://blog.tpa.me.uk/2013/11/11/slackware-14-1-new-initrd-luks-keyboard-issues/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No funciona el teclado en Slackware 14.1.

Publicado por Miguel (5 intervenciones) el 09/04/2014 16:35:43
Muchísimas gracias lo probaré y veré que tal, pero tiene muy buena pinta.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No funciona el teclado en Slackware 14.1.

Publicado por Miguel (5 intervenciones) el 12/04/2014 14:07:22
Ya esta solucionado, probe el script y funciono perfectamente, ya esta arreglado.

Muchisimas gracias.

Saludos a todos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar