Matlab - ayuda sobre Guide

   
Vista:

ayuda sobre Guide

Publicado por Raul (5 intervenciones) el 07/09/2009 18:02:55
por que al escribir guide en la ventana de comandos y luego de elegir Black GUI me sale esto?
??? Error using ==> copyfile
C:DOCUME~1ADMINI~1CONFIG~1Temp
Error in ==> guidetemplate at 88
copyfile(srcfigfile, targetfigfile, 'writable');

Error in ==> guide at 61
filename = guidetemplate;
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ayuda sobre Guide

Publicado por Diego Barragán (12 intervenciones) el 07/09/2009 19:22:18
Prueba reinstalando Matlab.

Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ayuda sobre Guide

Publicado por raul (5 intervenciones) el 08/09/2009 02:08:31
ya lo he vuelto a instalar.........y nada; lo he probado en otras máquinas y si funciona.........que pasa?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ayuda sobre Guide - La solución

Publicado por fismat (391 intervenciones) el 08/09/2009 06:00:55
Hola Raul,

El problema es producto de un bug en esa versión, aqui encontraras la solución :

http://www.mathworks.com/support/solutions/data/1-QDJCT.html?solution=1-QDJCT

Saludos
Fismat
-----------------------

Subject:
Why do I receive an error when opening a template in GUIDE or when using COPYFILE in MATLAB 7.0 (R14)?

Problem Description:
When I open GUIDE and select a template, I receive the following error:
??? Error using ==> copyfile
Error in ==> guidetemplate at 88
copyfile(srcfigfile, targetfigfile, 'writable');

Error in ==> guide at 61
filename = guidetemplate;
Alternatively, some customers experience an error message such as the following:
??? Error using ==> copyfile
'attrib' is not recognized as an internal or external command,
operable program or batch file.

Solution:
There is a bug in MATLAB R14 in the way it opens templates in GUIDE. It issues operating system commands like copy, attrib and when such commands are not found on the OS it throws these errors.

This bug has been fixed in Release 14 Service Pack 3 (R14SP3) in a way that it no longer depends on OS commands to open templates.

For previous product releases, read below for possible workarounds:

These error messages appear when your operating system's file copying command does not work as expected with MATLAB. To verify this, try using the "copy" command from a DOS command prompt.

1. Select "Run" from the "Start" menu.
2. Type "cmd" or "command" in the dialog box and click "OK".
3. At the DOS command prompt, type:

copy /?
If there is no output, then it is likely that the "copy" command is not on your system path.

If you are receiving an error regarding "attrib" not being recognizable, it indicates the "attrib" command is not on your system path. Similarly to the copy function, you can confirm this by typing the following in a DOS command window:

attrib /?
These files should be present in the windowssystem32 directory and this directory should be present in the system's path. If you are not able to locate these files on your system, please contact your system administrator or Microsoft's technical support department, since these files are not provided by MATLAB itself, but rather by the operating system.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ayuda sobre Guide - La solución

Publicado por Raul (5 intervenciones) el 13/09/2009 01:30:42
Bueno lo resolví, solo tenia que formatear mi máquina e instalar nuevamente el window, parece que la versión no era compatible..
Gracias por su ayuda de todas maneras...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar