Microcontroladores - Problema en MPLAB

   
Vista:

Problema en MPLAB

Publicado por Nacho (1 intervención) el 06/04/2010 15:01:25
Hola gente,
Estoy intentando generar una funcion para un pic p18f452. Estoy utilizando el MPLAB IDE con el compilador MCC18. El caso es que he conseguido compilar mi aplicacion bien, pero al hacer la simulacion dentro del entorno MPLAB, siempre obtengo el mismo error. He probado hasta los ejemplos que vienen con el MCC18 y sigue saliendome el mismo error:
--> CORE-W0014: Halted due to PC incrementing over the Maximum PC address and wrapping back to Zero

Alguien tiene alguna idea de por que puede ser?? Pense que mi aplicacion era demasiado grande o saltaba a alguna direccion de memoria erronea, pero al pasarme con los ejemplos que venian con el compilador, lo descarte.

Gracias de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

tambien necesito ayuda

Publicado por rodolfo (1 intervención) el 28/04/2010 06:33:40
Amigo has podido solucionar el problema, lo que he leído hasta ahora es que algunas versiones de mplab generan este error con algunos pic, específicamente el algún foro leí, que un amigo se tuvo que cambiar a la versión 8.30 de mplab para que se solucionara el problema, pero aún no entiendo el problema de fondo, yo utilizo mplab 8.5 y me genera el mismo error con la famila 12Fxxx y eso que hago las pruebas con casi tres líneas de código sencillas, para descartar que el programa sea muy grande, no he tenido problemas con los 16Fxxx. tu lo has solucionado?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar