Microsoft Exchange - Problemas creando un Directorio Virtual de OWA alterno con diferente tipo de autenticacion

   
Vista:

Problemas creando un Directorio Virtual de OWA alterno con diferente tipo de autenticacion

Publicado por TNT (1 intervención) el 04/06/2014 23:08:28
Tenemos Owa en Exchange 2013 con autenticacion FBA trabajando correctamente https://mail.dominio.com/owa
se necesita configurar un owavirtualdirectory adicional con diferente tipo de autenticacion windows integrated a traves del puerto 80 con acceso solo desde la LAN

Para ello desde el IIS se ha creado un site nuevo llamado "Intranet"
Y desde el EMC se procedio a crear los directorios virtuales a traves de los siguientes cmdlets:
New-OwaVirtualDirectory -Server Name_Server -WebSiteName "Intranet"
Set-OwaVirtualDirectory -identity "Name_Server\owa (Intranet)" -InternalUrl "http://correo.dominio.local/owa" -WindowsAuthentication $true -Basicauthentication $false -Formsauthentication $false

New-ECPVirtualDirectory -Server Name_Server -WebSiteName "Intranet"
Set-ECPVirtualDirectory -identity "Name_Server\ecp (Intranet)" -InternalUrl "http://correo.dominio.local/ecp" -WindowsAuthentication $true -FormsAuthentication $false

iisreset


Luego de ello el acceso a http://correo.dominio.local/owa es correcto con autenticacion integrated windows; pero el acceso al owa por medio de fba https://mail.dominio.com/owa se vuelve imposible, carga la pagina de logue, pero no valida las credenciales, aparentemente por temas de tipo de autenticacion
Al revisar el tipo de autenticado por powershell esta correcto con FormsAuthentication en true, sin embargo pareciera q el Exchange no lo entendiera asi y hay que restaurar dichos permisos

Por lo tanto realizo lo siguiente:

Set-OwaVirtualDirectory -identity "Name_Server\owa (Default Web Site)" -FormsAuthentication $false
Set-ecpVirtualDirectory -identity "Name_Server\ecp (Default Web Site)" -FormsAuthentication $true
Set-OwaVirtualDirectory -identity "Name_Server\owa (Default Web Site)" -FormsAuthentication $false
Set-ecpVirtualDirectory -identity "Name_Server\ecp (Default Web Site)" -FormsAuthentication $true
luego iisreset

y el acceso a https://mail.dominio.com/owa es ok .. pero http://correo.dominio.local/owa ya no autentica como windows integrated sino q magicamente realiza un redirect a https://correo.dominio.local/owa y es necesario ingresar credenciales para entrar el owa

Gracias por la ayuda de antemano
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Microsoft Exchange
- Cursos de Microsoft Exchange
información
Cursos y Temas de Microsoft Exchange
- Guía de usuario de Ximian Evolution
- Guía Práctica de Autoaprendizaje