MySQL - Sugieranme que version instalar, por favor

   
Vista:

Sugieranme que version instalar, por favor

Publicado por Leticia (3 intervenciones) el 18/11/2012 22:14:33
Saludos
al entrar a la pagina www.mysql.com
encuentro varias versiones y no se cual debo instalar.
requiero instalar un servidor con apache, php y mysql y no se cuales versiones elegir. y como configurarlas, pues ya he instalado algunas versiones y no puedo ver paginas en php todavia.
yo ya cuento con algo de programacion.
mil gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Sugieranme que version instalar, por favor

Publicado por Gonzalo GC (339 intervenciones) el 19/11/2012 00:31:11
Estás haciendo boludeces propias de un ignorante.
PHP y MySQL no son lo mismo, y no dependen el uno del otro. Puedes usar PHP toda la vida y jamás usar una base de datos o incluso jamás necesitar de MySQL como servidor de BBDD.
Apache tampoco es PHP, ni depende del PHP para existir. Apache es un server web, no un aplicativo concurrente de PHP.
Sería mejor que antes de seguir adelante, estudies verdaderamente y evitarás hacer pavadas.

Empecemos por el principio:

MySQL es un motor de base de datos, lo que se denomina en informática un SGBD (Sistema de Gestión de Base de Datos) o DBMS (Data Base Management System), que contiene los motores de tablas y el intérprete de SQL, y cuya función es exclusivamente la gestión de datos. Pero no tiene ninguna relación con PHP, más allá de ser el DBMS más usado (pero no el único) en ese lenguaje.

PHP es un lenguaje de scripts de uso general, que puede o no estar embebido en los script de HTML, y que se ejecuta en servidor. Por ello necesita de un WebServer para funcionar, pero no necesariamente Apache, aunque su funcionamiento en él es mejor que en otros.
PHP, como lenguaje de programación, es independiente de cualquier DBMS y lo que tiene son
librerías que permiten acceder a diferentes DBMS.

Apache es un Servidor Web HTTP de código abierto (Open Source), para diferentes plataformas, que permite soportar la ejecución de aplicaciones del lado del servidor, realizando conexiones bidireccionales donde tanto recibe peticiones como envía las respuestas de los diferentes aplicativos que en el corren. Uno de esos aplicativos es el PHP, si es que está instalado.

Entonces: Suponer que si instalas MySQL puedas hacer correr scripts de PHP, es algo que sólo los principiantes muy, pero muy básicos (categoría sub-troll), pueden hacer.
Lo mínimo que se exige en un foro es un nivel elemental de conocimientos, como por ejemplo diferenciar entre un lenguaje y un DBMS (lo del WebServer se puede disculpar). Al menos ten la decencia de leer Wikipedia antes de entrar preguntando estupideces.

Finalmente: Si hubieses consultado a San Google podrías haberte evitado la vergüenza, porque te habrías enterado que existen al menos cuatro paquetes muy usuales instalables que pueden ponerte el conjunto APM (Apache+PHP+MySQL) preconfigurado: WAMPServer, AppServ, EasyPHP y XAMPP. Todos ellos gratis, todos ellos fáciles de instalar, y todos ellos... usados por desarroladores en serio.
Estos detalles los hubieses encontrado simplemente poniendo en Google "php MySQL Apache" y listo..

VE a la pagina de Siftonic: http://www.softonic.com/s/apache-php-mysql-phpmyadmin


Y por favor, ten un poco de respecto a la profesión de desarrollador: No vuelvas a preguntar mostrando semejante ignorancia.
Es insultante.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
-1
Comentar

Sugieranme que version instalar, por favor

Publicado por Leticia (3 intervenciones) el 19/11/2012 19:26:31
Que grosero eres Gonzalo
yo ya tengo muy buena experiencia en otros lenguajes de programacion, pero ahora que quiero iniciarmen en mysql y php, pido apoyo y me topo con alguien como tu.
pero la verdad si no contestas es mejor. (no todos los programadores somos como tu, con tanta arrogancia, eso si da verguenza ajena.)
todos estos paquetes que mencionas ya vi que existen, solo queria me sugirieran algo.
realmente no aportas nada y de una manera tan grosera.
yo solo quiero montar mi propio servidor
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Sugieranme que version instalar, por favor

Publicado por xve (898 intervenciones) el 19/11/2012 20:53:45
Hola Leticia, tienes que descargarte la versión Community Server, que es la versión gratuita.
http://www.mysql.com/downloads/mysql/

Cualquier cosa...

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Sugieranme que version instalar, por favor

Publicado por Dalsom (23 intervenciones) el 20/11/2012 16:15:49
Utilizo Xampp,
evita problemas, y a menos que requieras de la ultima version de cada aplicacion, este resolvera tus necesidades como iniciado en Php, MySql y Apache.

Wampp hace lo mismo, pero prefiero el xampp.

Saludos desde Rep. Dom.
Dalsom
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Sugieranme que version instalar, por favor

Publicado por Leticia (3 intervenciones) el 27/11/2012 21:13:22
instale appserv y se instala todo en automatico.
mil gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Sugieranme que version instalar, por favor

Publicado por benjamin (2 intervenciones) el 08/01/2013 21:36:56
te iba a sugerir el appserv es muy bueno yo uso ese y lo del otro programador no hagas caso siempre hay gente asi como que si ya nacieron aprenidos saludos cualquier consulta avisame
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar