Netbeans - Problema con Netbeans 8 y Glassfish 4.1

   
Vista:

Problema con Netbeans 8 y Glassfish 4.1

Publicado por Milogus (2 intervenciones) el 25/03/2015 19:45:01
Que tal!
soy nuevo en el foro, espero me puedan ayudar.

Tengo una Web App desarrollada con jsp y servlets en Netbeans, hace conexiones a un servidor Glassfish 3.1 y funciona correctamente...
pero cuando la trato de correr en un Glassfish 4.1 me dice que un query tiene mala sintaxis puesto que funciona correctamente si lo copio/pego en terminal del SlqServer y con Glassfishv3 tambien funciona al 100%.

Alguna idea de lo que pueda ser?
o a alguien ya le pasó esto?

Espero me puedan ayudar, gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problema con Netbeans 8 y Glassfish 4.1

Publicado por Milogus (2 intervenciones) el 25/03/2015 22:17:40
Problema resuelto!
Por si alguien tiene algún error parecido en algun momento...

Lo que hice fue cambiar el "Resource Type" del archivo Web.XML del proyecto;
anteriormente tenía "javax.sql.DataSource", lo cambie por "java.net.URL" y funciona a la perfección
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de xve

Problema con Netbeans 8 y Glassfish 4.1

Publicado por xve (30 intervenciones) el 26/03/2015 11:01:57
Gracias por comentarlo!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema con Netbeans 8 y Glassfish 4.1

Publicado por Lugiui Renee Loo Jara (1 intervención) el 09/09/2016 19:55:20
Hola compañero, tengo un gran problema para iniciar mi netbeans y el glassfish server 4.1.1 .... lo que pasa es cuando doy Run ala applicaction me sale error por este motivo


1
2
3
4
5
6
7
8
9
10
11
12
13
14
ant -f C:\\Users\\telematica\\Documents\\aprendiendojsf\\aprendiendojsf -Dnb.internal.action.name=run -Ddirectory.deployment.supported=true -DforceRedeploy=false -Dnb.wait.for.caches=true -Dbrowser.context=C:\\Users\\telematica\\Documents\\aprendiendojsf\\aprendiendojsf run
init:
deps-module-jar:
deps-ear-jar:
deps-jar:
library-inclusion-in-archive:
library-inclusion-in-manifest:
compile:
compile-jsps:
In-place deployment at C:\Users\telematica\Documents\aprendiendojsf\aprendiendojsf\build\web
GlassFish Server 4.1.1, deploy, null, false
C:\Users\telematica\Documents\aprendiendojsf\aprendiendojsf\nbproject\build-impl.xml:1054: The module has not been deployed.
See the server log for details.
BUILD FAILED (total time: 7 seconds)

podrías ayudarme o darme alguna idea..?
se lo agradeceré
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar