Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Iniciar sesiónIniciar sesiónCrear cuentaCrear cuenta

Oracle - Error : 12514 No reconoce SERVICE-NAME

  Imprimir  
Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:

Error : 12514 No reconoce SERVICE-NAME

Autor:PAULINA (15 intervenciones)
Fecha:10/09/2002 00:28:41
Hola:
Mi problemas es el siguiente. Tengo dos bases de datos Oracle 8i en distintos servidores. La primera base de datos la logro ver y accesar, pero la segunda no, solo la veo y acceso desde el mismo servidor en donde está almacenada. Desde un cliente trato de acceder a ésta y me sale el siguiente error: Error 12514.TNS el listener no ha podido resolver el SERVICE_NAME especificado en el descriptor de conexión. Ya tengo creado el TNSNAMES.ORA con la base, la instancia, el port y el nombre del servicio, pero no me resulta la conexión; también ya tengo creado el DSN (ODBC) . Que puede estar faltando ?
Gracias...ojalá tenga buena acogida, es urgente...
Responder
información
Otras secciones de LWP con contenido similar...
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:Error : 12514 No reconoce SERVICE-NAME

Autor:Milson Cardona (26 intervenciones)
Fecha:10/09/2002 01:31:10
buenas tardes desde la hermosa república de COLOMBIA

Bueno,
te aconsejo que crees un nuevo SID(servicio de la instancia local) para la DB, esto lo puedes hacer por el net8 configuration assistent, y le definas bien el host, el port y SID de la DB y pruebes la conexión (es posible que tengas alguna información mala) esto es para estar seguros..

si esto no te funciona, en vez de el nombre del host, coloca la IP del servidor donde tienes la DB

NOTA: claro que los 2 puntos anteriores los puedes hacer más rápido si sabes configurar manualmente el TNSNAMES.ORA de la carpeta NETWORK \ ADMIN

si esto tampoco te funciona, prueba parando el servicio ORA817_TSNLISTENER, e inmediatamente lo vuelves a iniciar en el servidor e intenta conectarte, si esto te funciona la primera vez, pero la segunda ya no te conecta, vuelve a bajar este servicio..... si para conectarte siempre debes bajar el servico antes mencionado en el servidor OJO... debes volver a instalar el ORACLE 8i, y te aconsejo que lo hagas en el modo TYPICAL...

esto me ha pasado, cuando he instalado el ORACLE 8i en la forma CUSTOM, o cuando sin reinstalar el oracle 8i he borrado y vuelto a crear la DB

por favor, hazme saber la evolución de tu problema, para saber si te puedo seguir ayudando o si se me ocurre algo más.
Comentar