PHP - imagefill

   
Vista:

imagefill

Publicado por John (3 intervenciones) el 14/12/2009 16:39:01
Estimados amigos
Me estoy volviendo loco intentando que imagefill me rellene el background con el color que yo quiera. El caso es que en mi instalación local de xampp me pone el color correctamente. Sin embargo cuando lo ejecuto en el servidor, siempre me pone el color negro independientemente del color que especifique yo.
El código es:

<?php
//ini_set("display_errors", "1");error_reporting(E_ALL);

$im = imagecreatetruecolor(100, 100);

// sets background to red
$red = imagecolorallocate($im, 255, 0, 0);
$val = imagefill($im, 0, 0, $red);
header('Content-type: image/png');
imagepng($im);
imagedestroy($im);

?>
Cuando lo ejecuto en local me sale el color rojo que es el que debería salir de acuerdo al código, pero cuando lo ejecuto en remoto (www.arreglaordenador.com/numberimage2.php) siempre me pone el background en color negro.
¿a alguien se le ocurre alguna idea?
Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:imagefill

Publicado por Diego Romero (1450 intervenciones) el 14/12/2009 17:35:48
Lo único que se me ocurre que puede estar pasando es que la biblioteca GB sea diferente en tu máquina y en el servidor.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:imagefill

Publicado por John (3 intervenciones) el 14/12/2009 17:38:31
qué significa biblioteca GB? qué significa GB?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:imagefill

Publicado por Diego Romero (1450 intervenciones) el 15/12/2009 00:02:02
Me equivoqué, quise decir GD.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:imagefill

Publicado por John (3 intervenciones) el 15/12/2009 00:03:39
Expediente X porque ahora funciona pero el código sigue siendo el mismo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar