PHP - Problema con la matriz $_FILES en formuario

   
Vista:

Problema con la matriz $_FILES en formuario

Publicado por educhip (13 intervenciones) el 17/05/2011 14:15:43
Hola, estoy creando un script para subida de archivos mediente php, lo primero que necesito es conocer las propiedades del archivo, para ello he creado un formulario simple, y intento recuperar las propiedades del archivo imprimiendo el contenido d la matriz $_FILES pero obtengo el siguiente error o más bien NOTICE:


Notice: Undefined index: file_upload in C:\wamp\www\subir_archivos_php\subiendo_archivos2.php on line 5

Aquí dejo el código php:

<?php
if(isset($_POST["submit"]))
{
echo "<pre>";
print_r($_FILES["file_upload"]);
echo "</pre>";
}
?>

El formulario en el <body> de la página es:

<form action="subiendo_archivos2.php" method="post" ecntype="multipart/form-data">
<input type="hidden" name="MAX_FILE_SIZE" value="1000000" />
<input type="file" name="file_upload" value=""/>
<input type="submit" name="submit" value="Subir archivo" />
</form>

Es decir que no reconoce el valor file_update con lo cuál no puede mostrar el contenido de la matriz $_FILES:

¿Alguien sabe a que puede deberse?

Gracias y saludos !!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Problema con la matriz $_FILES en formuario

Publicado por xve (5522 intervenciones) el 17/05/2011 15:04:57
Hola Educhip, puede ser porque hay un error de escritura?

ecntype="multipart/form-data">

tiene que ser:

enctype="multipart/form-data">

Coméntame, ok?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema con la matriz $_FILES en formuario

Publicado por educhip (13 intervenciones) el 17/05/2011 15:45:13
Hola xve, gracias por tu respuesta pero no la entiendo, me dices que debe ser:

ecntype="multipart/form-data">

y así es:

ecntype="multipart/form-data">

No sé a que error te refieres....
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Problema con la matriz $_FILES en formuario

Publicado por xve (5522 intervenciones) el 17/05/2011 16:28:18
Error ortográfico... es: enctype="multipart/form-data">

creo que lo tienes mal escrito.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar