Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Iniciar sesiónIniciar sesiónCrear cuentaCrear cuenta

PHP - localhost y php

  Imprimir  
Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:

localhost y php

Autor:joan antoni joanantoniferrerfunes@yahoo.es (8 intervenciones)
Fecha:16/08/2011 14:37:06
Hola, mi nombre es Joan y tengo el IIS en el localhost correcto.

Pero a la hora de ejecutar ficheros .php o .html no se me visualiza nada en el explorador.
Yo creo que debe ser una configuracion de windows 7, pero no se.

He probado con el path dec:/php, con las dll's, etc..
Creo que debe ser algo mas sencillo.
Responder
información
Otras secciones de LWP con contenido similar...
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

localhost y php

Autor:Alexis (92 intervenciones)
Fecha:17/08/2011 03:20:39
¿Cómo ejecutas el archivo .php?
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

localhost y php

Autor:joan ferer JOANANTONIFERRERFUNES@YAHOO.ES (8 intervenciones)
Fecha:18/08/2011 16:27:53
Lo hago con http://localhost/archivo.php
Lo tengo grabado en el htdocs

La cuestión es que no se si es del navegador o es de windows, pero el navegador no me imprime nada. A veces me sale un error HTML 404.0, o no me sale nada.
Y antes desde el dreamweaver también podía probar html con el navegador. Pero este no me imprime nada.
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

localhost y php

Autor:Alexis (92 intervenciones)
Fecha:19/08/2011 03:22:47
¿Puedes enviar el código fuente que estás intentando ejecutar? Tal vez allí esté el problema porque si antes podías ejecutarlo y no has tocado la configuración del servidor, entonces será algo del código. También indica cual es tu servidor local y más o menos como está configurado
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

localhost y php

Autor:joan ferrer joanantoniferrerfunes@yahoo.es (8 intervenciones)
Fecha:20/08/2011 00:35:06
Pues es este

<¿php
phpinfo();
?>

o

<?php
echo "HOLA MUNDO";
?>

El tema es que no se me imprime nada o da un error 404.0. Y del servidor, en la opción optionalfeatures.exe tengo todo activado ( El IIS, etc..).
Tengo un localhost que cuando lo ejecuto me sale una pantalla del Internet Information Service.
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

localhost y php

Autor:Sebastian darkpormen@gmail.com (25 intervenciones)
Fecha:20/08/2011 09:36:06
Hola Joan:
Si usas windows 7 te recomiendo que instales el wamp server, ya que te instala todos los servicios y es mas facil realizar modificaciones, yo lo probe y nunca tuve problemas con el pruebalo, tambien otra falla que pude estar ocurriendo es que tengas ocupado el puerto 8080 el cual escucha el servidor posiblemente con algun motor de base de datos, te recomiendo verificar el puerto en el documento de apache, se llama htdocs.conf busca la linea que dice listen si aparece 8080 cambialo por ejemplo a 8050 reinicias el servidor apache y luego para volver a entrar al servidor si es que realizaste esta modificacion seria:
http://localhost:8050/
si despues tienes problemas solo comenta...
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

localhost y php

Autor:joan ferrer joanantoniferrerfunes@yahoo.es (8 intervenciones)
Fecha:23/08/2011 13:22:44
Gracias, ya lo he conseguido.
He desinstalado el TeamViewer y el Skype porque ocupaban algun puerto, y he desintalado todas las instancias de apache y los he vuelto a grabar desde el cd que acompaña al libro de php.

En httpd.conf solo he añadido estas tres lineas :

LoadModule php5_module c:/php/php5apache2_2.dll
AddType application/x-httpd-php .php .html
PhpIniDir "C:/php/"

Y ya funciona .
Comentar