PHP - Problemas con PHP, Apache 2.2 y SQLServer 2005

   
Vista:

Problemas con PHP, Apache 2.2 y SQLServer 2005

Publicado por Pakor (2 intervenciones) el 24/07/2012 14:06:24
Hola:

Tengo un sistema montando Apache 2.24, PHP 5.3.15 en una plataforma WinXP SP3 y esto funciona correctamente.

A mayores esoty tratando de configurarlo para que acceda a una base de datos SQLServer 2005 expres.

Leyendo documentacíon he bajado una version de modulos de PHP para acceder a SQLServer.

En ella especifica que tengo que usar "php_sqlsrv_53_ts_vc6.dll" y "php_pdo_sqlsrv_53_ts_vc6.dll" para acceder a SQLServer 2005 desde PHP 5.3.x usando Apache 2.2x en plataforma WinXP SP3.

Configuro el php.ini añadiendo "extension=php_sqlsrv_53_ts_vc6.dll", arranco apache y no da problemas, pero cuando trato de acceder a las funciones de acceso a SQLServer de apache (ejemplo sqlsrv_connect()) me debuelve el mensaje "Call to undefined function sqlsrv_connect() ". Es decir, parece que no ve las librerias de acceso a sqlserver.

Uso versiones Thread Safety y al hacer el phpinfo() me da que Thread Safety is enabled.

¿Alguna idea? porque ya no se me ocurre mucho mas.

Gracias y un saludo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Problemas con PHP, Apache 2.2 y SQLServer 2005

Publicado por xve (5518 intervenciones) el 24/07/2012 16:45:45
Hola Pakor, revisa en el phpinfo si te ha cargado la extensión que has añadido...

De todas maneras, te recomiendo utilizas la clase PDO, con ella no deberías de tener mayor problema. Nosotros siempre la hemos estado utilizando y nos ha funciona perfectamente.

Espero que te sirva.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas con PHP, Apache 2.2 y SQLServer 2005

Publicado por pakor (1 intervención) el 26/07/2012 08:53:05
He comprobado el phpinfo, pero es que no carga las extensiones indicadas. No encuentro cual es el problema. ¿Que se supone que hay que hacer en el php.ini para cargar las extensiones? He estado tocando la variable Path del sistema para incluir las rutas al directorio de extensiones, pero tampoco he conseguido nada.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas con PHP, Apache 2.2 y SQLServer 2005

Publicado por edwincito (1 intervención) el 27/09/2012 15:13:19
Discupen yo tengo el mismo problema será que alguien de favor muy especial brinda ayuda...necesito de urgencia o de pronto alguna sugerencia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Problemas con PHP, Apache 2.2 y SQLServer 2005

Publicado por xve (5518 intervenciones) el 27/09/2012 16:29:24
Hola Pakor, has probado a utilizar PDO??
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar