PHP - PHPAGI

   
Vista:

PHPAGI

Publicado por guillermo HC (4 intervenciones) el 14/01/2013 19:47:28
SOY NUEVO CON ASTERISK Y ESTOY TRATANDO DE REALIZAR EL SIGUIENTE EJEMPLO CON PHPAGI PERO NO ME MUESTRA NADA EL CLI DE ASTERISK
TENGO EL SIGUIENTE ARCHIVO EN:
/var/lib/asterisk/agi-bin/tamal.php

TAMAL.PHP contiene:
<?php
set_time_limit(30);
ob_implicit_flush(true);//IMPLICITAMENTE BORRA EL BUFFER
require('phpagi/phpagi.php');
error_reporting(E_ALL);
$agi = new AGI();
if ($agi->answer())
{

echo "Bienvenido GUILLERMO";
}
else
{
echo "Error al conectarse \n";
}
$agi->hangup();
?>

PERO EL CLI DE ASTERISK NO ME MUESTRA LA IMPRESION "Bienvenido GUILLERMO", PORQUE?

== Using SIP RTP CoS mark 5
-- Executing [101@phones:1] Answer("SIP/102-00000000", "") in new stack
-- Executing [101@phones:2] AGI("SIP/102-00000000", "tamal.php") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/tamal.php
-- <SIP/102-00000000>AGI Script tamal.php completed, returning 0
-- Executing [101@phones:3] Hangup("SIP/102-00000000", "") in new stack
== Spawn extension (phones, 101, 3) exited non-zero on 'SIP/102-00000000'
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

PHPAGI

Publicado por fergie (1 intervención) el 27/05/2013 06:31:10
Hola amigo disculpa pudiste corregir el error, es que yo tengo el mismo problema y no encuentro la solución.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar