PHP - Problemas de instalación WAMP

   
Vista:
Imágen de perfil de Gustavo

Problemas de instalación WAMP

Publicado por Gustavo giragus@hotmail.com (7 intervenciones) el 22/11/2013 21:06:52
Baje el WAMP y lo instalé sin problemas. Comencé con los primeros ejercicios del curso de PHP, pero no puedo abrir ningún archivo .php porque me dice que "No se encuentra la página" "HTTP 404 – File not found" y lo mismo ocurre al querer abrir MySQL.

Desde ya, muchas Gracias.


PD: Los foros están llenos de normas y reglas y cuando un novato comete un error, le pegan para el campeonato. POR FAVOR, TENGAN PACIENCIA.

GRACIAS
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Problemas de instalación WAMP

Publicado por xve (5520 intervenciones) el 23/11/2013 07:47:37
Hola Gustavo, que url tienes puesta en el navegador? tanto para acceder a tus páginas como para acceder al MySQL?

Puede ser que WAMP no este ejecutando el servidor Apache?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Gustavo

Problemas de instalación WAMP

Publicado por Gustavo giragus@hotmail.com (7 intervenciones) el 23/11/2013 19:14:28
Gracias por tu respuesta

Para los ejercicios use estas dos (y más):

http://localhost/pagina1.php
file:///C:/\wamp/www/pagina1.php

También cambié el nombre del archivo: index.php y otros
La url del MySQL no la se.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Problemas de instalación WAMP

Publicado por xve (5520 intervenciones) el 24/11/2013 20:49:07
Hola Gustavo, la primera url es la correcta... y si te devuelve error 404 es que Apache esta en funcionamiento.

Entonces, creo que el problema, únicamente puede estar en la ubicación del archivo en tu disco duro... donde has puesto el archivo pagina1.php en tu disco duro?

Si no recuerdo mal, tienes que poner tu archivo en la carpeta: htdocs de donde has instalado el wamp

Nos puedes comentar?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Gustavo

Problemas de instalación WAMP

Publicado por Gustavo (7 intervenciones) el 26/11/2013 20:28:46
El archivo lo puse en:

C:\wamp\www

Pero al ponerlo en

C:\wamp\bin\apache\apache2.2.22\htdocs

Pasa lo mismo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Problemas de instalación WAMP

Publicado por xve (5520 intervenciones) el 26/11/2013 22:20:15
Es muy estraño gustavo... ahora no tengo ningun wamp instalado, pero lo pruebo y te comento...

habria que ver donde apunta el VirtualHost del apache, ya que en principio tendria que apuntar a www

que versión de wamp tienes instalada? y sobre que sistema operativo?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Gustavo

Problemas de instalación WAMP

Publicado por Gustavo (7 intervenciones) el 27/11/2013 18:25:05
Probé con
wampserver2.2e-php5.4.3-httpd2.2.22-mysql5.5.24-32b.exe (27,1 MB (28.425.387 bytes))
y con
wampserver2.2e-php5.4.3-httpd2.2.22-mysql5.5.24-32b.exe (34,3 MB (36.019.739 bytes))

En XP 32 (bits)

Gracias por engancharse!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas de instalación WAMP

Publicado por Elier (92 intervenciones) el 26/11/2013 19:34:55
El icono de Wamp debe salirte en verde en la barra, si no lo ves ve a programas y ejecuta wamp. Luego copia tus archivos php para c:\wamp\www y en el navegador http://localhost/pagina1.php

Verifica en en el archivo con nombre hosts que esta dentro de la carpeta C:\Windows\System32\drivers\etc tiene una linea que dice:

127.0.0.1 localhost
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Gustavo

Problemas de instalación WAMP

Publicado por Gustavo (7 intervenciones) el 26/11/2013 20:40:17
El ícono aparece en naranja.
En programas tengo start WampServer, pero se está ejecutándose wampmanager.exe
En efecto, el archivo:

C:\Windows\System32\drivers\etc\hosts

contiene la linea (es la primera)

127.0.0.1 localhost
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas de instalación WAMP

Publicado por Elier (92 intervenciones) el 27/11/2013 16:31:37
Dale clic al icono de wamp y dale stop all services y después start all services. Si el icono sigue naranja ve a la carpeta C:\wamp\logs y revisa en los logs que esta fallando. Si te sigue dando problemas descargate la última versión de WAMP para tu sistema operativo.

Windows XP (32 bits)

http://sourceforge.net/projects/wampserver/files/WampServer%202/Wampserver%202.4/Wampserver2.4-x86.exe/download

Windows 7 (64 bits)

http://sourceforge.net/projects/wampserver/files/WampServer%202/Wampserver%202.4/Wampserver2.4-x64.exe/download

Haz una salva de la carpeta C:\wamp\www y también un salva de las bases de datos que tengas en MySQL, luego desinstala WAMP, si queda la carpeta wamp bórrala. Instala la nueva version para ver si se te resuelve el problema.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Gustavo

Problemas de instalación WAMP

Publicado por Gustavo (7 intervenciones) el 27/11/2013 18:44:18
No quiero ser pesado, pero te paso todo el mysql.log
Tengo el rígido freezado, así que cada ves que reinicio, se desinstala (No lo instale desfreezado, porque no funciona)
Estoy bajando la nueva versión.
Gracias

mysql.log

131127 14:36:21 [Note] Plugin 'FEDERATED' is disabled.
131127 14:36:22 InnoDB: The InnoDB memory heap is disabled
131127 14:36:22 InnoDB: Mutexes and rw_locks use Windows interlocked functions
131127 14:36:22 InnoDB: Compressed tables use zlib 1.2.3
131127 14:36:23 InnoDB: Initializing buffer pool, size = 128.0M
131127 14:36:23 InnoDB: Completed initialization of buffer pool
InnoDB: The first specified data file .\ibdata1 did not exist:
InnoDB: a new database to be created!
131127 14:36:23 InnoDB: Setting file .\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
131127 14:36:23 InnoDB: Log file .\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
131127 14:36:23 InnoDB: Log file .\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: 127 rollback segment(s) active.
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
131127 14:36:24 InnoDB: Waiting for the background threads to start
131127 14:36:25 InnoDB: 1.1.8 started; log sequence number 0
131127 14:36:25 [Note] Server hostname (bind-address): '(null)'; port: 3306
131127 14:36:25 [Note] - '(null)' resolves to '::';
131127 14:36:25 [Note] - '(null)' resolves to '0.0.0.0';
131127 14:36:25 [Note] Server socket created on IP: '0.0.0.0'.
131127 14:36:25 [Note] Event Scheduler: Loaded 0 events
131127 14:36:25 [Note] wampmysqld: ready for connections.
Version: '5.5.24-log' socket: '' port: 3306 MySQL Community Server (GPL)
131127 14:38:38 [Note] wampmysqld: Normal shutdown

131127 14:38:38 [Note] Event Scheduler: Purging the queue. 0 events
131127 14:38:38 InnoDB: Starting shutdown...
131127 14:38:39 InnoDB: Shutdown completed; log sequence number 1595675
131127 14:38:39 [Note] wampmysqld: Shutdown complete

131127 14:38:42 [Note] Plugin 'FEDERATED' is disabled.
131127 14:38:42 InnoDB: The InnoDB memory heap is disabled
131127 14:38:42 InnoDB: Mutexes and rw_locks use Windows interlocked functions
131127 14:38:42 InnoDB: Compressed tables use zlib 1.2.3
131127 14:38:42 InnoDB: Initializing buffer pool, size = 128.0M
131127 14:38:42 InnoDB: Completed initialization of buffer pool
131127 14:38:42 InnoDB: highest supported file format is Barracuda.
131127 14:38:42 InnoDB: Waiting for the background threads to start
131127 14:38:43 InnoDB: 1.1.8 started; log sequence number 1595675
131127 14:38:43 [Note] Server hostname (bind-address): '(null)'; port: 3306
131127 14:38:43 [Note] - '(null)' resolves to '::';
131127 14:38:43 [Note] - '(null)' resolves to '0.0.0.0';
131127 14:38:43 [Note] Server socket created on IP: '0.0.0.0'.
131127 14:38:43 [Note] Event Scheduler: Loaded 0 events
131127 14:38:43 [Note] wampmysqld: ready for connections.
Version: '5.5.24-log' socket: '' port: 3306 MySQL Community Server (GPL)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas de instalación WAMP

Publicado por Elier (92 intervenciones) el 28/11/2013 15:47:57
El servidor MySQL al parecer arrancó correctamente, como la aplicacion para administrarlo también es una aplicacion web en PHP de seguro te da error, te aconsejo que instales esta herramienta

http://download2.sqlmanager.net/download/mymanager/mymanager_lite.zip

e intentes conectarte a MYSQL por esa vía, si todo funciona bien, ya puedes descartar a MYSQL, y centrarte en el APACHE o en PHP, si activaste alguna extensión en PHP o modificaste algún archivo de configuración de APACHE revisa nuevamente para que descartes que hayas cometido algun errror.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Gustavo

Problemas de instalación WAMP

Publicado por Gustavo (7 intervenciones) el 28/11/2013 16:25:03
Gracias.

Probaré!

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar