PHP - Un problema con el IF

   
Vista:
Imágen de perfil de Jose Manuel

Un problema con el IF

Publicado por Jose Manuel josemlperez2001@gmail.com (4 intervenciones) el 23/03/2014 01:51:02
Hola amigos como estan mi problema es el siguiente tengo este codigo.

1
2
3
4
5
6
7
8
9
10
11
12
13
<?php
if (isset($_POST['ads_name']) && !empty($_POST['ads_name']) &&
	isset($_POST['ads_title']) && !empty($_POST['ads_title']) &&
	isset($_POST['ads_web_link']) && !empty($_POST['ads_web_link']) &&
	isset($_POST['ads_side']) && !empty($_POST['ads_side']) &&
	isset($_POST['ads_image']) && !empty($_POST['ads_image']) &&
	isset($_POST['ads_category']) && !empty($_POST['ads_category']))
{
	$conexion = mysql_connect($host,$user;$pass) or die("The Hosting Information not is correctly");
	mysql_select_db($base,$conexion) or die("The Data Base don't EXIT");
 
}
?>

y cuando quiero usar el "else" no me permite me da un error y se pone rojo cuando lo pongo alguien me pueden ayudar.
Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Un problema con el IF

Publicado por xve (5515 intervenciones) el 23/03/2014 20:50:49
Hola Jose Manuel, parece que esta todo correcto, pero no veo el else al que haces referencia...

Cuando dices que se te pone en rojo, donde te lo muestra en rojo?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Jose Manuel

Un problema con el IF

Publicado por Jose Manuel josemlperez2001@gmail.com (4 intervenciones) el 24/03/2014 02:34:13
Si no lo puse pero tengo esta informacion.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
<?php
include ("conection.php");
 
if(isset($_POST['ads_name']) && !empty($_POST['ads_name']) &&
isset($_POST['ads_title']) && !empty($_POST['ads_title']) &&
isset($_POST['ads_image']) && !empty($_POST['ads_image']) &&
isset($_POST['ads_web_link']) && !empty($_POST['ads_web_link']));
{
	$conexion = mysql_connect($host,$user,$pass) or die("La coneccion no se a efectuado");
	mysql_select_db($base,$conexion)or die("La coneccion no se a efectuado en bd");
	mysql_query("INSERT INTO baseads (ADSNAME,TITLE,WEBLINK,SIDE,IMAGE,CATEGORY) VALUES ('$_POST[ads_name]','$_POST[ads_title]','$_POST[ads_web_link]','$_POST[ads_side]','$_POST[ads_image]','$_POST[ads_category]')",$conexion);
	echo "Datos Insertado Corectamente";
}
else{   //<--------------------------------------- Comentario ----------------------------------------Aqui se pone rojo
	echo "Revise Sus Datos.";
}
?>
y este error es en el explorador

Parse error: syntax error, unexpected 'else' (T_ELSE) in C:\xampp\htdocs\textphp\adssend.php on line 13
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Un problema con el IF

Publicado por xve (5515 intervenciones) el 24/03/2014 08:40:00
Hola Jose Manuel, quita el punto y coma que hay al final del paréntesis del "if(...);"

Coméntanos, ok?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Jose Manuel

Un problema con el IF

Publicado por Jose Manuel josemlperez2001@gmail.com (4 intervenciones) el 24/03/2014 22:12:07
Hola Gracias, ya lo habia tratado de esa forma pero no funciono y ahora misteriosamente funciona , ahora una cuantas preguntas mas tengo un anexo en el script para subir una imagen a una carpeta no me sube la imagen y me dice estos errores
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
<?php
include ("conection.php");
 
if(isset($_POST['ads_name']) && !empty($_POST['ads_name']) &&
isset($_POST['ads_title']) && !empty($_POST['ads_title']) &&
isset($_POST['ads_image']) && !empty($_POST['ads_image']) &&
isset($_POST['ads_web_link']) && !empty($_POST['ads_web_link']))
{
	$conexion = mysql_connect($host,$user,$pass) or die("La coneccion no se a efectuado");
	mysql_select_db($base,$conexion)or die("La coneccion no se a efectuado en bd");
	mysql_query("INSERT INTO baseads (ADSNAME,TITLE,WEBLINK,SIDE,IMAGE,CATEGORY) VALUES ('$_POST[ads_name]','$_POST[ads_title]','$_POST[ads_web_link]','$_POST[ads_side]','$_POST[ads_image]','$_POST[ads_category]')",$conexion);
	/*--------------------------------------------------------------*/
//Subir Imagen en el archivo
	/*--------------------------------------------------------------*/
	$carpeta = "files/";
	opendir($carpeta);
	$destino = $carpeta.$_FILES['ads_image']['name'];
	copy ($_FILES['ads_image'] ['tmp_name'],$destino);
	echo "archivo subido correctamente";
 
	$nombre = $_FILES['ads_image']['name'];
 
	echo  "<img src=\"$nombre\">";
 
	echo "Datos Insertado Corectamente";
}else{
	echo "Revise Sus Datos.";
}
?>
estos son los errores
Notice: Undefined index: ads_image in C:\xampp\htdocs\textphp\adssend.php on line 17

Notice: Undefined index: ads_image in C:\xampp\htdocs\textphp\adssend.php on line 18

Warning: copy(): Filename cannot be empty in C:\xampp\htdocs\textphp\adssend.php on line 18
archivo subido correctamente
Notice: Undefined index: ads_image in C:\xampp\htdocs\textphp\adssend.php on line 21
Datos Insertado Corectamente
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Un problema con el IF

Publicado por xve (5515 intervenciones) el 25/03/2014 07:54:48
Hola Jose Manuel, lo que te esta diciendo es que $_FILES['ads_image'] no existe!!

Nos puedes mostrar el formulario?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Jose Manuel

Un problema con el IF

Publicado por Jose Manuel josemlperez2001@gmail.com (4 intervenciones) el 25/03/2014 17:47:14
Si lo entiendo pero no se porque lo dice por que esa variable si existe. esa es la pregunta?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Un problema con el IF

Publicado por xve (5515 intervenciones) el 25/03/2014 18:43:42
Creo que el problema esta en el formulario... nos lo puedes mostrar?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar