PHP - Cacao de Versiones PHP

   
Vista:

Cacao de Versiones PHP

Publicado por Victor (193 intervenciones) el 13/11/2014 12:30:03
Buenas tardes.

En post anteriores he comentado que lo que en mi host funciona bien una vez que lo subo al servidor no va tan bien.
Dandole vueltas al coco he caido en la cuenta de mirar las versiones de PHP con las que estoy trabajando,si versiones al parecer son varias.Os comento:
PhpStorm,el IDE con el que trabajo dice que trabajo con la version PHP 5.0.4
Xampp,el servidor de mi host,segun el phpInfo dice que es la version 5.4.7
Hostinger,el servidor con el que trabajo,pone que tiene la version 5.2,pero en este caso la puedo cambiar.

Bueno,dicho esto tengo unas cuantas preguntas.

1.Puede tener esto que ver con el asunto de que en comportamiento en mi host es diferente(en mi host las cosas van bien) del la web del servidor?

2.Que hago para arreglarlo,por que en hostinger si puedo elegir que version de PHP utilizo pero en jetBrain PhpStorm no sé como se hace.

Gracias por vuestro tiempo,saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Cacao de Versiones PHP

Publicado por Ismael (41 intervenciones) el 13/11/2014 18:56:48
Hola Victor,
que te sucede exactamente.
En cuanto a las distintas versiones de PHP claro que puede alterar el comportamiento o dejar de funcionar, hay funciones que de una versión a otra pueden dejar de funcionar, por ejemplo la funcion htmlentities:

En PHP 5.6 y posterior, la opción de configuración default_charset se emplea como valor predeterminado. PHP 5.4 y 5.5 utilizarán UTF-8 como valor predeterminado. Las versiones anteriores de PHP emplean ISO-8859-1.

Aquí este forma diferente de comportamiento puede alterar una cadena a la hora de tratar acentos o caracteres especiales.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar