PHP - Me muestra tildes y eñes como interogantes

   
Vista:

Me muestra tildes y eñes como interogantes

Publicado por txunda txunda@ono.com (5 intervenciones) el 11/05/2016 13:46:56
Hola a todos,

De la noche a la mañana, sin haber hecho ningún cambio en el código, hoy me he encontrado que en mi web salen mal todos los acentos y eñes.

Me sucede desde todos los navegadores (IE, Firefox, Chrome,...)

Tengo insertada la línea: <meta http-equiv="Content-type" content="text/html;charset=UTF-8">.

No me soluciona el problema el sustituir los caracteres por &aacute; &eacute; etc... porque cuando coge el texto de una base de datos mediante PHP, tendría que coger esos datos y mediante una función sustituir las tildes por su correspondiente &xcute; ...cosa que me parece un poco chapuza, con perdón.

En fin, agradezco cualquier idea.

Lo curioso es que tengo otras páginas, incluso alojadas en el mismo servidor, y con la misma codificación y se leen perfectamente.

Gracias a tod@s!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Me muestra tildes y eñes como interogantes

Publicado por xve (5519 intervenciones) el 11/05/2016 15:45:25
Hola Txunda, si se te ha cambiado sin hacer nada, puede ser por algun cambio en el servidor... nos puedes indicar la url?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Me muestra tildes y eñes como interogantes

Publicado por txunda txunda@ono.com (5 intervenciones) el 11/05/2016 16:50:08
Hola xve,
Es una página privada sencillita donde guardo todos mis entrenamientos y otros datos, si hay alguna forma de pasárte la URL en privado te la mando encantado, pero no quiero ponerla en el foro.
Gracias!

Por si te sirve de algo aquí te pongo las primeras líneas del codigo de la página de entrada index.php, que como puedes ver, también salen mal los acentos en mi nombre:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<HTML lang="es-ES" dir="ltr" xmlns="http://www.w3.org/1999/xhtml">
<HEAD>
<TITLE>Mis Entrenamientos - TXUNDA</TITLE>
<meta http-equiv="Content-type" content="text/html;charset=UTF-8">
<META name="copyright" content="Txunda">
<META name="author" content="Chema Santamar�a Garc�a">
<META name="description" content="Mis entrenamientos - Txunda">
<link rel="STYLESHEET" type="text/css" href="estilos_misentrenamientos.css">
<link rel="STYLESHEET" type="text/css" href="contenedores.css">
</HEAD>
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de VRM

Me muestra tildes y eñes como interogantes

Publicado por VRM (171 intervenciones) el 12/05/2016 07:44:22
Hola:

Prueba a poner la linea siguiente inmediatamente después de la etiqueta <HEAD>
1
<meta charset="UTF-8">

Saludos de Víctor.-
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Me muestra tildes y eñes como interogantes

Publicado por txunda txunda@ono.com (5 intervenciones) el 12/05/2016 09:48:10
Nada, siguen apareciendo los interrogantes...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Me muestra tildes y eñes como interogantes

Publicado por Chema txunda@ono.com (5 intervenciones) el 12/05/2016 13:22:59
SOLUCIONADO!!

Según los administradores del servidor donde tengo alojadas las páginas, el problema es la versión de .PHP del servidor, con la última versión no funcionaba bien, he puesto la versión anterior y se visualiza todo perfectamente.

Gracias a todos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Me muestra tildes y eñes como interogantes

Publicado por xve (5519 intervenciones) el 12/05/2016 15:25:30
Hola Chema, gracias por comentarlo, pero cual es la última versión que tienen?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Me muestra tildes y eñes como interogantes

Publicado por Chema txunda@ono.com (5 intervenciones) el 12/05/2016 15:53:06
Ahora está funcionando con la v 5.3, pero desde el CPANEL se puede cambiar a otra superior, pero entonces se visualiza mal la web, un poco raro, la verdad!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar