Power Builder - PB 10 + DCOM ..!! ya no me funciono..!!!

   
Vista:
Imágen de perfil de LEONARDO DANIEL

PB 10 + DCOM ..!! ya no me funciono..!!!

Publicado por LEONARDO DANIEL (75 intervenciones) el 21/01/2011 22:18:46
Hola a todos.:!!

Resulta que estoy desarrollando una aplicacion, en la cual cree un objecto COM+ con unas funciones que haran procesos remotos, ke son pesados en el servidor..

Lo que hice fue generar la DLL, ir al server, instar el runtime de PB, entrar a servidor de componentes, crear el nuevo, registrar el componente.

luego desde mi PC llamaba a ese objeto con ConnecttoNewRemoteObject

todo funcionaba bien, solo que algo se movio en el server, no se ke fue lo que paso, que si me conecta al objeto, pero cuanto intento accesar a las funciones, me dice "acceso denegado" ya le di mil vueltas, algunos documentos en internet dicen que es cuestion de permisos, pero pues ya le dije que lo corra hasta el mismo administrador.!

desesperando dije, bueno a ver si funciona en el mismo server la aplicacion, y si.!

pero ya pormedio de la red no me deja.!!

ya intentente desde visual foxpro

oPB = CREATEOBJECTEX("{AEC211E1-2F75-4CD4-8BD7-0DBE0F3ABE54}","gast_edu05")

valor = oPB.of_texto("holaa mundo")

esto deberia regregsar "el texto es: hola mundo"

pero marca tambien error acceso denegado

si embargo al escribir oPB. me despliega los metodos ..!

ya no se ke hacer.!! urgeeeeeeeeeeeeeeeeeeeeeee

nota..!! no se cuenta con EAS como para desarrollarlo asi, asi ke tuve ke recurrir a DCOM
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder