Power Builder - Consumo web service power builder 9

   
Vista:

Consumo web service power builder 9

Publicado por Jose Manuel (14 intervenciones) el 31/05/2014 11:12:21
Hola :

Estoy intentando consumir un servicio web con power builder 9.0.

Lo estoy haciendo con la dll que me he descargado MSSOAP30, y la he copiado
en Windows system32.

El codigo es el siguiente , el cual me da error en la siguiente linea,
que es la llamada a un metodo el web service:
lx_xml = soapClient.ATEX_CONSULTA_TITULAR("1","2"),


// codigo que utilizo
OleObject soapClient
any la_rc
string lx_xml



soapClient = CREATE OLEObject
la_rc = soapClient.ConnectToNewObject("MSSOAP.SoapClient30")
If (la_rc <> 0) Then
MessageBox("RC",String(la_rc))
End If

la_rc = soapClient.MSSoapInit("http://192.168.1.36:8080/ah2013_tris/ah2013_tris?wsdl")
MessageBox("RC",String(la_rc))


lx_xml = soapClient.ATEX_CONSULTA_TITULAR("1","2")

soapClient.DisconnectObject()
Destroy(soapClient)
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antonio

Consumo web service power builder 9

Publicado por Antonio (1114 intervenciones) el 03/06/2014 04:58:54
hola Jose:

con PB 9.0 no te puedo decir cual es el error, pero desde la versión 10,11.0 , 11.5 ya usas el SOAPCONNECTION del mismo PowerBuilder y es mucho mas sencillo.

Te recomiendo que migres te ahorraras mucho trabajo y ya no dependerás de ninguna DLL ya que consumes el Web Service directo del link que te mandan

suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar