Redes - red vpn entre routers

   
Vista:
Imágen de perfil de ivan

red vpn entre routers

Publicado por ivan (1 intervención) el 23/04/2014 13:34:12
Hola amigos.
Bueno lo que pasa es que quiero crear un tunel vpn entre los routers R1 - R3, y entre R1 - R4, como se muestra en la siguiente imagen.



El tunel entre R1 - R3 me funciona bien y puedo hacer ping entre PC1 y PC3, pero cuando hago ping entre la pc's de R1 - R4 me aparece el siguiente mensaje en el router R4 "%CRYPTO-4-RECVD_PKT_NOT_IPSEC: Rec'd packet not an IPSEC packet. (ip) vrf/dest_addr= /192.168.4.3, src_addr= 192.168.1.3, prot= 1" , no entiendo cual es el error , por favor si alguien sabe como puedo resolverlo.
A continuacion muestro la configuracion que utilizo en los router:

configuracion de R1:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
R1#show runn
Building configuration...
 
Current configuration : 1206 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
crypto isakmp policy 10
 encr aes
 authentication pre-share
 group 2
!
crypto isakmp key vpnpass address 10.2.2.2
crypto isakmp key vpnpass address 10.3.3.2
!
!
crypto ipsec transform-set VPN-SET esp-3des esp-sha-hmac
!
crypto map VPN-MAP 10 ipsec-isakmp
 set peer 10.2.2.2
 set peer 10.3.3.2
 set transform-set VPN-SET
 match address 110
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.1.1.1 255.255.255.252
 clock rate 64000
 crypto map VPN-MAP
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 192.168.1.0
 network 10.1.1.0 0.0.0.3
 no auto-summary
!
ip classless
!
!
access-list 110 permit ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255
access-list 110 permit ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Configuracion de R3:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
R3#show runn
Building configuration...
 
Current configuration : 1112 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
crypto isakmp policy 10
 encr aes
 authentication pre-share
 group 2
!
crypto isakmp key vpnpass address 10.1.1.1
!
!
crypto ipsec transform-set VPN-SET esp-3des esp-sha-hmac
!
crypto map VPN-MAP 10 ipsec-isakmp
 set peer 10.1.1.1
 set transform-set VPN-SET
 match address 110
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.3.3.1 255.255.255.252
 clock rate 64000
!
interface Serial0/0/1
 ip address 10.2.2.2 255.255.255.252
 crypto map VPN-MAP
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 192.168.3.0
 network 10.2.2.0 0.0.0.3
 network 10.3.3.0 0.0.0.3
 no auto-summary
!
ip classless
!
!
access-list 110 permit ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Configuracion de R4:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
R4#show runn
Building configuration...
 
Current configuration : 1112 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
!
!
!
!
!
!
crypto isakmp policy 10
 encr aes
 authentication pre-share
 group 2
!
crypto isakmp key vpnpass address 10.1.1.1
!
!
crypto ipsec transform-set VPN-SET esp-3des esp-sha-hmac
!
crypto map VPN-MAP 10 ipsec-isakmp
 set peer 10.1.1.1
 set transform-set VPN-SET
 match address 110
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.4.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.3.3.2 255.255.255.252
 crypto map VPN-MAP
!
interface Serial0/0/1
 ip address 10.4.4.1 255.255.255.252
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 192.168.4.0
 network 10.3.3.0 0.0.0.3
 network 10.4.4.0 0.0.0.3
 no auto-summary
!
ip classless
!
!
access-list 110 permit ip 192.168.4.0 0.0.0.255 192.168.1.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

gracias de antemano y Saludos a todos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Marcos

red vpn entre routers

Publicado por Marcos (43 intervenciones) el 26/04/2014 15:14:38
Si la comunicacion entre R1 y R3 no tiene problema, significa que la configuracion de ambos esta bien, el problema estaria en R4, revisa IPSEC como te dice en el mensaje
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar