SQL Server - problemas en inserts

   
Vista:

problemas en inserts

Publicado por nani (3 intervenciones) el 27/03/2014 00:59:44
Hola a todos.
Tengo una aplicación .Net (de momento no tengo acceso a las fuentes) que inserta paquetes de registros (entre 10 y 200), más o menos continuamente en un W2000 con SQL server 2000. Cuando cambio la configuración y le hago apuntar a un Sql server 2005 bajo W2008, aparentemente todo va bien, pero hay paquetes que no inserta, y no sé el motivo, No sé como trazar el problema, o si hay algún parámetro de configuración del sql que pueda modificar para aceptar esas entradas masivas.
¿Alguien me puede ayudar?
Muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Isaias

problemas en inserts

Publicado por Isaias (3186 intervenciones) el 27/03/2014 06:49:10
¿Cómo estas haciendo los INSERTs?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problemas en inserts

Publicado por nani (3 intervenciones) el 27/03/2014 08:21:39
Pues no sé si la aplicación .Net recorre un recordset y va insertando, o envía todo el paquete de datos a un procedimiento almacenado. Estoy intentando conseguir las fuentes, a ver si veo el modus operandi
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Isaias

problemas en inserts

Publicado por Isaias (3186 intervenciones) el 27/03/2014 19:47:20
Según veo tu comentario en FDW ya resolviste el problema
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problemas en inserts

Publicado por nani (3 intervenciones) el 28/03/2014 08:35:03
Sí, con tanto lío que tengo se me olvidó cerrar este hilo! ¡ Lo siento ! Transcribo aquí la resolución:

Gracias!, ¡Parece solucionado!
Con el Profiler encontré que la aplicación llama a un procedimiento almacenado (olvidé comentar que yo no he hecho el proyecto, y no sabía ni que procedimientos tenía), y los parámetros que le pasa en el momento que da error, y al ejecutarlo directamente en el manager, me devuelve el error más detallado, algo así como que no está habilitado el procedimiento xp_cmdshell en la configuración de superficie. No sé ni lo que es tal configuración ni lo que hace ese procedimiento (si alguien me lo explica se lo agradezco) ni por qué unas veces se le invoca y otras no, ni como lo hace, pero el caso es que buscando por la web encontré la forma de habilitar ese SP de sistema, y ahora parece que todo va bien!
Gracias y saludos!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar