SQL Server - Consulta lenta en LAN cuando falla internet

   
Vista:

Consulta lenta en LAN cuando falla internet

Publicado por Dalsom (22 intervenciones) el 13/05/2014 03:27:55
Hola a todos,

Tengo Sql 2008, 2008 R2, 2012 y 2014 instalado en mi pc para pruebas, todas versiones express o developer. Y varias aplicaciones que accesan a distintas base de datos sql.

He notado que al tener problemas mi internet, ponerse lento, o incluso cortarse, todas mis consultas a SQL aunque sean de forma local en el mismo servidor de Sql directamente, se ponen lentas en extremo. Pasa con todas las versiones antes mencionadas.

Siempre uso el Protocolo TCP/IP como unico protocolo habilitado, pero dadas las circuntancias, he intentado habilitando los demas protocolos, y de igual forma mi consultas estan lentas cuando el internet tiene retardos o se corta.
En el caso del servidor, de forma local, me desconecto de la base de datos, apago el router del internet, y luego con el internet abajo, me vuelvo a conectar a mi base de datos, y las consultas corren sin problema alguno.

Alguna idea de como solucionar este problema?

Utilizo ODBC para conectarme a la BD.

Les agradezco la ayuda de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Isaias

Consulta lenta en LAN cuando falla internet

Publicado por Isaias (3181 intervenciones) el 13/05/2014 20:40:49
No hay relación, te sugiero que revises la aplicación de tus service pack
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Consulta lenta en LAN cuando falla internet

Publicado por Dalsom dalsom@yahoo.com (22 intervenciones) el 19/05/2014 04:53:00
Listo Isaias, muchas gracias. Aqui le dejo la solucion temporal (y creo que no recomendada) a este caso en particular.

El problema consiste aun, en el firewall del windows. Una vez desactivado, todo corrio mas rapido.

Se que al abrir los puertos TCP 1433 y UDP 1434 se permite tener el firewall activo, pero, entonces pasa
lo descrito arriba, que concidencialmente pasaba cuando estaba defectuoso el internet. Se pone todas las consultas lentas, por lo que he desactivado el Firewall para la red local.

Que me ha faltado por configurar, ya que he abierto los puertos descritos anteriormente. No uso DTS, Replicacion o Mails de SQL.

Desde ya muchas gracias, espero esto tambien ayude a otros con el mismo problema.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar