SQL Server - Conexion remota a ms sql desde web remota (problemas)

   
Vista:

Conexion remota a ms sql desde web remota (problemas)

Publicado por Artemio (1 intervención) el 28/11/2014 23:31:39
Buen dia, espero que me puedan ayudar.
No se mucho de programacion pero me gusta y le agarro facilmente e investigo lo mas que puedo pero con esto ya no se que pasa.
Tengo 1 pc con windows server 2008, ms sql server 2008 express with advanced services y xampp 1.7.3 configure conexiones remotas y el firewall del modem y de la pc servidor. puedo conectarme, local, desde red y segun yo deberia de conectar desde internet.
Adquiri una web para acceder desde mi dominio y web a las bd de mi servidor casero hice un archivo de prueba.php para checar la conexion con el sql el cual contiene esto:
<?php

$db_link = mssql_connect("lineage2mx.sytes.net,1433","sa","pasword");

if(!$db_link){
die;
}
echo 'Conectado';
?>

y cuando trato de acceder desde mi web me sale lo siguiente:

Warning: mssql_connect() [function.mssql-connect]: Unable to connect to server: lineage2mx.sytes.net,1433 in /home/tantramx/public_html/prueba.php on line 3

Segun yo el servidor esta correcto y debe de aceptar las coexiones remotas y el problema puede ser de la web, aun asi no me quede tranquilo y como tengo 2 conexiones de internet en otra pc instale el win xp, el sql server con servicios avanzados 2005 y el xammp 1.7.3, deshabilite firewall y active las conexiones remotas y el los puertoes en el firewall del otro modem y entre mis dos servidores funciona bien el archivo prueba .php . osea lo puse en la pc servidor, en la pc con xp claro cada uno con los datos del sql de la otra y me funciona bien, e resultado es el siguiente:
conectado

el hosting esta en neubox y al php le puse la version 5.2 y le seleccione el mssql_conect.

Segun yo el servidor esta bien y esta aceptando conexiones remotas pero desde el hosting web no funciona... alguien tiene alguna idea de que podria ser?
No se si pueda ser diferencia de versiones o que el hosting web utiliza apache y yo estoy utiizando xampp 1.7.3
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder