Symfony - Problema con Arrays en TWIG

   
Vista:

Problema con Arrays en TWIG

Publicado por Sergio (3 intervenciones) el 21/10/2013 10:02:37
Buenos días,

Hola,

Acabo de terminar una web basada en PHP en la que utilizo twig como motor de plantillas. Todo funciona correctamente a excepción del comportamiento de los arrays. En mi servidor local son iterables y las recorre sin problema. En el servidor web, con el mismo código, dice que no son iterables.

¿Alguien sabe por qué puede estar pasando esto?

El código es el siguiente:

{% if datos is defined %}

{% if datos is iterable %}

{% for dato in datos %}

{{ ... }}

{% endfor %}

{% endif %}

{% endif %}

Insisto. En local me funciona perfectamente y muestra el contenido de "datos". En el servidor web me dice que datos no es iterable.

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problema con Arrays en TWIG

Publicado por Sergio (3 intervenciones) el 21/10/2013 10:33:16
Me contesto a mi mismo porque he dado con la causa del problema.

Le estaba pasando a la plantilla un objeto mysqli con los datos. Por el motivo que sea, la plantilla no sabe interpretar el objeto mysqli y por tanto no puede recorrer el array y mostrar los datos.
He preguntado al hosting pero por el momento no me han contestado.

A voz de pronto, la solución rústica que se me ocurre es convertir el objeto mysqli en un array asociativo manualmente tras realizar cada consulta.
Voy a investigar más a ver si se puede resolver de una forma más o menos elegante.

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de xve

Problema con Arrays en TWIG

Publicado por xve (6 intervenciones) el 21/10/2013 14:31:40
Gracias por comentarlo Sergio!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar