TeX/Latex - Problema referenciando figuras

   
Vista:

Problema referenciando figuras

Publicado por nitaderobin (8 intervenciones) el 15/08/2011 11:46:09
Hola buenas.

Tengo un problema con las figuras de mi tesis.
En el pie de foto están bien numeradas y todas ellas tienen su \label{} definido.

El problema es que cuando me refiero a ellas en el texto, en vez de aparecer el número de la figura en concreto, aparece el número de la sección en la que está.

Esto no me pasaba antes y no sé que he podido tocar para que esto ocurra. No se me ocurre nada, la verdad.

Tenéis alguna idea de lo que puede estar pasando?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problema referenciando figuras

Publicado por nitaderobin (8 intervenciones) el 15/08/2011 12:05:59
Ya he resuelto el problema. La solución estaba en otro post de este foro llamado "figuras mal numeradas".

Es un problema de la versión. Se ha debido actualizar sin que me de cuenta.
Se resuelve poniendo el \label dentro del \caption de esta forma...

\caption{\label{}................}

Gracias de todos modos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema referenciando figuras

Publicado por nitaderobin (8 intervenciones) el 15/08/2011 12:19:00
Ah y se me olvidaba deciros el toque mágico...

Compilar tres veces seguidas... ¿Alguien entiende algo? yo no... pero así funciona.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Problema referenciando figuras

Publicado por eugip9 (21 intervenciones) el 15/08/2011 19:02:39
A mí me solía pasar que se refería a la versión cuando dejaba una línea entre el caption y el label. Pero si las pones como

\caption{...}
\label{...}

debería de referenciartelas bien, compilando 2 veces para ello.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema referenciando figuras

Publicado por nitaderobin (8 intervenciones) el 15/08/2011 19:36:55
Así es como lo estaba haciendo, incluso a veces lo ponía en la misma línea
\caption{}\label{}

Y ni compilando 10 veces... eso no funcionaba...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema referenciando figuras

Publicado por eugip9 (21 intervenciones) el 15/08/2011 19:53:15
Pues de verdad que debería de funcionar así, prueba a hacer un documento nuevo que ponga:

1
2
3
4
5
6
7
8
9
10
11
12
13
\documentclass[10pt,a4paper]{article}
 
\begin{document}
 
En la figura \ref{fig::prueba} ...
 
\begin{figure}
	Frase de prueba.
	\caption{Frase de prueba.}
	\label{fig::prueba}
\end{figure}
 
\end{document}


y lo compilas 2 veces. Si el resultado es el esperado (el resultado es "En la figura 1") quizás el problema esté en alguno de los paquetes que has cargado. Si no es así, probablemente el problema esté en la versión de Miktex o Tex Live (lo que utilices).
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema referenciando figuras

Publicado por Rava (1 intervención) el 30/04/2014 20:10:09
IDOLO!!!!

Estuve unos días dando vuelta pensando que podían ser los nombres de los archivos. Porque algunos tenían _ ya que si tienen espacios también es posible que se rompa todo.

Muchas Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema referenciando figuras

Publicado por Arnold Fernández Rivas arnoldfiarn@gmail.com (5 intervenciones) el 04/07/2012 02:54:51
Hola amigos, en mi caso sucedió lo mismo, he trabajado sobre una plantilla que en la que ya existían figuras referenciadas, y pues no sé a qué se deba pero no me funcionaba a mí cuando adapté el contenido (ojo que no adapté ningún paquete). Te agradezco la solución, no se me hubiera ocurrido en mila años. Ojalá alguien pueda explicar cuál es el problemilla.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar