Visual Basic para Aplicaciones - Problema con Formato

Life is soft - evento anual de software empresarial
   
Vista:

Problema con Formato

Publicado por Albert (108 intervenciones) el 15/04/2009 20:02:12
Estimados foreros, tengo un problema de formato al generar un informe, debo poner el signo "%" despues de la cifra lo he intentado con

Hoja4.Cells(43, 6) = Format(Hoja4.Cells(43, 6), "#,## %")

Cambiando el signo, así es como pongo el signo de "€", pero en este caso me multiplica por 100, he probado varias cosas pero todas me dan error por lo que acudo a vosotros por si me podeis ayudar (como siempre)

Mil gracias de antemano
Albert
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de JuanC

RE:Problema con Formato

Publicado por JuanC (431 intervenciones) el 15/04/2009 20:34:03
Hoja4.Cells(43, 6) = Format(Hoja4.Cells(43, 6), "#,##")
Hoja4.Cells(43, 6).Value = Hoja4.Cells(43, 6).Value & "%"

en todo caso deberás poner el formato de la celda en Texto
Hoja4.Cells(43, 6).NumberFormat = "@"

Saludos desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con Formato

Publicado por Albert (108 intervenciones) el 15/04/2009 20:43:44
Como siempre perfecto
Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar