Visual Basic para Aplicaciones - Escribir formula de excel con Macro

Life is soft - evento anual de software empresarial
   
Vista:

Escribir formula de excel con Macro

Publicado por Pedro (1 intervención) el 03/02/2010 17:26:48
Saludos Amigos

Estoy haciendo una macro para insertar formulas en celdas de excel.

La formula es

=si(B3=C2;"Ok";"Venta Perdida")

y sigue en secuencia para las celdas siguientes

He llegado bien hasta esto:

formula = "=SI(B" + CStr(j + 1) + "=C" + CStr(j) + ";""O" + "k"";""Venta Perdida"")"
MsgBox (formula)

pero al momento que asigno el texto de la formula a la celda de la siguiente forma:

formula = "=SI(B" + CStr(j + 1) + "=C" + CStr(j) + ";""O" + "k"";""Venta Perdida"")"
MsgBox (formula)
Worksheets("Cara " + CStr(cont)).Cells(j + 1, 4).Value = formula

Me sale un error 1004

Espero su ayuda para poder solucionar esto

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de JuanC

RE:Escribir formula de excel con Macro

Publicado por JuanC (431 intervenciones) el 03/02/2010 19:48:34
quizá se deba a que usás ; (punto y coma) en lugar de , (coma)

Saludos, desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Escribir formula de excel con Macro

Publicado por Unai (1 intervención) el 10/01/2013 17:35:28
Hola,

en lugar de asignarlo a la propiedad 'Value' lo tienes que hacer a la propiedad 'Formula', es decir

Worksheets("Cara " + CStr(cont)).Cells(j + 1, 4).Formula = formula

un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar