Visual Basic.NET - Un poco de lío con las versiones .NET

   
Vista:

Un poco de lío con las versiones .NET

Publicado por angi (3 intervenciones) el 18/05/2015 13:58:33
Hola, bueno soy muy novato en todo esto, Hace como 10 años que no toco nada de programación.

La duda es que queria hacer un CD instalador con un autorun y mi idea es que pueda ser compatible con los Windows, desde el XP hasta el 8 y no se como va el tema de la compatibilidad del .Net.

Veo que hasta Windows 7 va incluida la 2.0 pero en cuanto a trabajar con un entorno de programación no sé como empezar.

¿Qué entorno me puedo instalar para desarrollar en 2.0? ¿O como funciona?

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Wilfredo Patricio Castillo

Un poco de lío con las versiones .NET

No entendí nada, que es lo que necesitas, que es eso que va incluida la 2.0 y que en cuanto a trabajar con un entorno de programación no se como empezar.

Qué entonces me puedo instalar para desarrollar en 2.0?

Qué o que?.

La verdad no dijiste nada, que es eso de que la 2.0? o que realmente necesitas o que quieres preguntar?.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Un poco de lío con las versiones .NET

Publicado por angi (3 intervenciones) el 19/05/2015 10:32:52
jajaja perdona entonces.

Me gustaría desarrollar un CD con autorun que funcione con cualquier Windows recién instalado. Pensad en un CD de drivers de placa base. Pues lo mismo.

El problema de un Windows recién instalado es que no tienen todos los framework instalados de serie. Por ejemplo:
- Xp viene con la 1.0
- Vista con la 2.0, 3.0
- 7 con la 2.0, 3.0, 3.5
- 8 con la 4.5

La pregunta es, ¿cómo puedo asegurarme que un programa que voy a hacer sólo necesita de la versión del framework 2.0 instalada en los PCs de los clientes?

¿O lo planteo de otra forma como hacer varios ejecutables para cada versión de Framework (una para la 1.0, otra para la 3.0 y otra para la 4.5?

Eso es el lío que tengo.

Gracias por la ayuda y aclararme
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Un poco de lío con las versiones .NET

Publicado por Miguel (350 intervenciones) el 19/05/2015 15:29:07
Hola, respondo a continuación:

1) Si usas librerías, etc. debes revisar que usen el mismo .NET Framework que la aplicación.

2) En Visual Studio, al crear un nuevo proyecto puedes elegir la versión .NET Framework de destino.

La siguiente página te puede servir para consultar el .NET Framework del ordenador: https://msdn.microsoft.com/es-es/library/hh925568(v=vs.110).aspx


Saludos,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Wilfredo Patricio Castillo

Un poco de lío con las versiones .NET

Hola

Si te estabas refieiendo al .NET Framework, lo mas recomendable es que siempre uses la última versión, pero cuando inicias un nuevo proyecto tienes la opción de seleccionar que versión usar.

Ahora que si quieres tener varias versiones del .Net Framework, puedes incluirlo como prerrequisito la versión y adjuntarla en una carpeta en tu aplicación, simplemente los descargas desde la página de microsoft y los incluyes.

Saludos cordiales
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Un poco de lío con las versiones .NET

Publicado por angi (3 intervenciones) el 20/05/2015 10:27:29
Muchas gracias a ambos por las respuestas.

Me han sido muy útiles
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar