Visual Basic.NET - Problema con crystal report y visual studio 2010

   
Vista:

Problema con crystal report y visual studio 2010

Publicado por Luis (4 intervenciones) el 08/01/2016 15:32:18
Buenos dias amigos acudo a ustedes con la finalidad de que puedan echarme una mano, tengo un proyecto en visual studio 2010 con base de datos en mysql he creado un reporte con Crystal Report pero al momento de correr mi aplicacion me genera el siguiente error


error-visual

Mi codigo para cargar el data set es el siguiente:

1
2
3
4
5
6
7
8
9
Dim ds As New DataSet
 Dim consultaMarcas As String
 
            consultaMarcas = "SELECT cedula,nombre FROM prueba"
 
            adaptadorMarcas.SelectCommand = New MySqlCommand(consultaMarcas, conexion)
            adaptadorMarcas.Fill(ds)
            adaptadorMarcas.SelectCommand.Connection = conexion
            adaptadorMarcas.SelectCommand.ExecuteNonQuery()

y para el reporte es el siguiente:

1
2
3
4
5
6
7
Dim rpt As New CrystalReport3
        Try
            rpt.SetDataSource(ds)
            CrystalReportViewer1.ReportSource = rpt
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

Tambien hice una prueba exportando el resultado de la consulta de la base de datos a un archivo xml e igual me da el mismo error
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de giancarlo

Problema con crystal report y visual studio 2010

Publicado por giancarlo giangbd5@hotmail.com (280 intervenciones) el 08/01/2016 17:29:11
tengo mis dudas en el siguiente comando:

adaptadorMarcas.SelectCommand.ExecuteNonQuery()

porque execute nonquery, da como resultado el numero de filas afectadas, no un query, para eso deberías usar un fill o parecido
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Problema con crystal report y visual studio 2010

Publicado por Luis (4 intervenciones) el 09/01/2016 15:07:36
Giancarlo acomode el codigo y llenar el dataset de un mejor manera estaba colocando lineas de codigo que no estaba utillizando.
Saludos y Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Wilfredo Patricio Castillo

Problema con crystal report y visual studio 2010

Para evitar ese error asegúrate que la última línea de tu app.config sea idéntica a esta, solo copia y pega y asunto solucionado:

<startup useLegacyV2RuntimeActivationPolicy="true"><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup>

Saludos cordiales,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Problema con crystal report y visual studio 2010

Publicado por Luis (4 intervenciones) el 09/01/2016 15:09:05
Wilfredo habia revisado en una gran cantidad de paginas y probado una gran cantidad de codigos y nada ninguno funcionaba, realice lo que tu me dijiste ahora si me funciona perfectamente el informe sin ningun problema.

Muchas gracia y saludos desde Venezuela
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Wilfredo Patricio Castillo

Problema con crystal report y visual studio 2010

Pues que bueno hombre, que te haya servidor, cualquier otra duda por acá estamos.

Saludos cordiales,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar