Visual Basic.NET - Problemas con MDI Forms

   
Vista:

Problemas con MDI Forms

Publicado por Geovanni Escalante (8 intervenciones) el 27/06/2008 06:30:00
Hola a todos

Tengo un problema con mi formulario MDI resulta que yo voy a mostrar un formulario y yo lo tengo configurado en diseño que salga maximizado pero no me sale del todo maximizado y cuando lo maximizo dandole click al formulario en el boton de maximizar si se me maximiza todo, yo quiero que salga enseguida maximizado

el codigo es el siguiente:

NewForm_Click

FrmHijo.MdiParent = Me
FrmHijo.Show

probe tambien colocando en

FrmHijo_Load

Me.MdiParent = FrmPadre
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas con MDI Forms

Publicado por Elvis Alberto (19 intervenciones) el 28/06/2008 19:59:58
Hola:
Yo tenia ese problema tambien y lo solucione desde el formulario principal poniendo asi:
frmPedidos.Size = New Size(Me.Width - 5, Me.Height - 5), despues de asignarle el mdiparent. Fue la unica forma, ya que aparentemente, cuando le cambias la propiedad WindowState solamente se debe referir a que el tamaño actual del formulario es el maximizado, y te pone el MaximazedControl como que esta maximizado.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con MDI Forms

Publicado por Geovanni Escalante (2 intervenciones) el 29/06/2008 21:51:01
Elvis gracias por tu ayuda

Hice lo que me dijiste pero sigo con el mismo problema, no se si es que aparte de eso hay que hacer otras cosa que aún no he hecho.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con MDI Forms

Publicado por Elvis Alberto (19 intervenciones) el 01/07/2008 16:38:48
Eso que te sugeria lo estas poniendo en el formulario principal desde donde tenes el evento NewForm_Click o lo estas haciendo en el evento frmHijo_Load...?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con MDI Forms

Publicado por Geovanni Escalante (2 intervenciones) el 04/07/2008 04:37:21
Gracias ya solucioné el problema, era que lo estaba poniendo en el Form_Load del formulario Hijo y era del padre

Gracias compañero.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar