Visual Basic - Formulas Excel Desde vb6.0

Life is soft - evento anual de software empresarial
   
Vista:

Formulas Excel Desde vb6.0

Publicado por JUAN m-a-t-e-o-12@hotmail.com (32 intervenciones) el 01/06/2015 18:46:47
Hola amigos

Tengo una aplicación creada en vb6.0 que me exporta datos a excel hasta hay todo va estupendo

el problema se me presenta con las formulas.
como le hago para que cuando envié una formula me copie la formula de la celda anterior

ejemplo: en la celda D3 hay la siguiente formula =SUMA(A3+B3-C3)

al momento de enviar mi formula desde vb6.0 a excel me debería quedar así: " en la celda D4 =SUMA(A4+B4-C4) "

pero en realidad me queda así " =SUMA(A3+B3-C3) "

intente copiar la celda anterior y pegarla ala celda siguiente pero no me resulto, me echan una manito porfa

este es el código que utilizo

.Cells(co1, 4).value = " =SUMA(A3+B3-C3) "

lo que espero en las celdas D3 en adelante seria esto
D4 " =SUMA(A4+B4-C4) "
D5 " =SUMA(A5+B5-C5) "
D6 " =SUMA(A6+B6-C6) "
etc..





De ante manos muchas gracias y saludos desde colombia
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder