XML - porque no me funciona este codigo???

   
Vista:

porque no me funciona este codigo???

Publicado por Andrés (2 intervenciones) el 14/10/2008 06:03:40
no entiendo porque no me funciona este codigo para poner en mi pagina, lo hice con tres tracks al principio y funcionaba de maravilla y le puse dos mas y se daño, ni siquiera el editor de xml de office me lo recibe... que hago? qué tiene mal?

<?xml version="1.0" encoding="utf-8"?>
<playlist version="1" xmlns="http://xspf.org/ns/0/">
<trackList>

<track>
<title>río, lo Nuevo de Aterciopelados</title>
<creator>Ideaviva</creator>
<location>http://www.freewebs.com/ideavivaradio/imacontain/RIO.png</location>
<info>http://www.elespectador.com/entretenimiento/agenda/musica/articulo-rio-el-nuevo-disco-de-aterciopelados</info>
</track>

<track>
<title>Serrat en el Palacio</title>
<creator>Ideaviva</creator>
<location>http://www.freewebs.com/ideavivaradio/imacontain/SERRAT.png</location>
<info>http://bogota.vive.in/musica/bogota/conciertos/agosto2008/EVENTO-WEB-FICHA_EVENTO_VIVEIN-4442814.html</info>
</track>

<track>
<title>Elton John próximamente</title>
<creator>Ideaviva</creator>
<location>http://www.freewebs.com/ideavivaradio/imacontain/ej.png</location>
<info>http://bogota.vive.in/musica/bogota/articulos_musica/septiembre2008/ARTICULO-WEB-NOTA_INTERIOR_VIVEIN-4575997.html</info>
</track>

<track>
<title>Fito en Bogotá</title>
<creator>Ideaviva</creator>
<location>http://www.freewebs.com/ideavivaradio/imacontain/fito.png</location>
<info>http://bogota.vive.in/musica/bogota/articulos_musica/octubre2008/ARTICULO-WEB-NOTA_INTERIOR_VIVEIN-4584993.html</info>
</track>

<track>
<title>Conoce lo nuevo de sara</title>
<creator>Ideaviva</creator>
<location>http://www.freewebs.com/ideavivaradio/imacontain/sara.png</location>
<info>http://www.sarabmusic.com/</info>
</track>

<track>
<title>EM en el colombia Fest</title>
<creator>Ideaviva</creator>
<location>http://www.freewebs.com/ideavivaradio/imacontain/REM.png</location>
<info>http://bogota.vive.in/musica/bogota/conciertos/octubre2008/EVENTO-WEB-FICHA_EVENTO_VIVEIN-4594021.html</info>
</track>

</trackList>
</playlist>
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:porque no me funciona este codigo???

Publicado por Mukuykak (59 intervenciones) el 15/10/2008 05:12:56
Saludos, Andrés.

Tu problema radica en que usas el encoding utf-8; teniendo este tipo de encoding limitas el lenguaje en tu archivo, pues está diseñado para escribir en inglés, esto es, sin acentos o letras como la Ñ. Si te fijas, desde el inicio tienes una palabra acentuada ("río"). Si le quitases el acento, entonces te marcaría otro error, en la palabra "próximamente".
Para solucionar tu problema, cambia el encoding a "iso-8859-1".
Buen día.
=0)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:porque no me funciona este codigo???

Publicado por Andrés (2 intervenciones) el 15/10/2008 05:43:21
y cómo hago eso?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:porque no me funciona este codigo???

Publicado por OscaRo (2 intervenciones) el 15/10/2008 23:24:55
Solo pon en lugar de encoding="utf-8"

pones

encoding="iso-8859-1"

listo...

saludos...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar