Algoritmia - Algoritmo sobre sueldos y años trabajados

 
Vista:
sin imagen de perfil

Algoritmo sobre sueldos y años trabajados

Publicado por luis castro (2 intervenciones) el 21/06/2018 00:38:22
1 Realizar un algoritmo que solicite el sueldo y los años de antigüedad de varios trabajadores. El programa debe informar:
a) Si el sueldo es inferior a 450 000 y su antigüedad es igual o superior a 10 años, otorgarle un aumento del 20 %, mostrar el sueldo con el aumento a pagar.
b)Si el sueldo es inferior a 450 000 pero su antigüedad es menor a 10 años, otorgarle un aumento de 5 %, mostrar el sueldo con el aumento a pagar.



2 Realizar un algoritmo que permita ingresar el peso (en kilogramos) de piezas de metal.
El proceso termina cuando el usuario indique que no desea registrar más piezas.

Se debe informar:
a) ¿Cuántas piezas tienen un peso entre 9.8 Kg. y 10.2 Kg.?

b) ¿Cuántas con más de 10.2 Kg.?

c) ¿Cuántas con menos de 9.8 Kg.?

d) La cantidad total de piezas procesadas
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 110
Oro
Ha aumentado 1 puesto en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

Algoritmo sobre sueldos y años trabajados

Publicado por dario (32 intervenciones) el 21/06/2018 06:56:59
Te dejo este codigo a ver si te ayuda.
Esta en pseudocodigo.
Salu2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
//Ejercicio Nro 1
INICIO
	flag = 1
 
	mientras (flag == 1)
		leer (sueldo) // lee los sueldo, termina cuando sueldo = 0
		leer (antiguedad) //anios de antiguedad
		si (sueldo == 0)
			flag = 0 //sale del ciclo while
		sino
			si (sueldo < 450000) y (antiguedad >= 10)
				aumento = (sueldo * 0.20) //20%
				total = sueldo + aumento
				imprimir(total)
			fin-si
 
			si (sueldo < 450000) y (antiguedad < 10)
				aumento = (sueldo * 0.05) //5%
				total = sueldo + aumento
				imprimir(total)
			fin-si
		fin-si
	fin-mientras
FIN
 
//Ejercicio Nro 2. Usando arreglos (arrays)
INICIO
	piezas = [] //arreglo vacio
	opcion = 's'
	i = 1 //para contar las piezas
	x = y = z = 0 //pones las variables a cero
 
	mientras opcion == 's'
		leer(peso) //lee el peso de la pieza de metal
		piezas[i] = peso
		imprimir('Desea ingresar otra pieza s/n: ')
		leer(opcion)
		si opcion == 's'
			i = i + 1
		sino
			break //sale del ciclo mientras
		fin-si
	fin-mientras
 
	para j = 1 hasta i
		si piezas[j] >= 9.8 y piezas[j] <= 10.2
			x = x + 1
		sino si piezas[j] > 10.2
			y = y + 1
 
		sino
			z = z + 1
		fin-si
	fin-para
 
	imprimir(x) //numero de piezas >= 9.8 y <= 10.2
	imprimir(y) //numero de piezas > 10.2
	imprimir(z) //numero de piezas < 9.8
	imprimir(i) //numero total de piezas
FIN
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil

Como seria utilizando Pseint ??

Publicado por luis castro (2 intervenciones) el 23/06/2018 21:55:30
Como seria utilizando Pseint ??


1 Realizar un algoritmo que solicite el sueldo y los años de antigüedad de varios trabajadores. El programa debe informar:
a) Si el sueldo es inferior a 450 000 y su antigüedad es igual o superior a 10 años, otorgarle un aumento del 20 %, mostrar el sueldo con el aumento a pagar.
b)Si el sueldo es inferior a 450 000 pero su antigüedad es menor a 10 años, otorgarle un aumento de 5 %, mostrar el sueldo con el aumento a pagar.



2 Realizar un algoritmo que permita ingresar el peso (en kilogramos) de piezas de metal.
El proceso termina cuando el usuario indique que no desea registrar más piezas.

Se debe informar:
a) ¿Cuántas piezas tienen un peso entre 9.8 Kg. y 10.2 Kg.?

b) ¿Cuántas con más de 10.2 Kg.?

c) ¿Cuántas con menos de 9.8 Kg.?

d) La cantidad total de piezas procesadas
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 110
Oro
Ha aumentado 1 puesto en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

Como seria utilizando Pseint ??

Publicado por dario (32 intervenciones) el 24/06/2018 05:59:07
Ejercicio Nro 1 PSeint

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
Algoritmo trabajadores
	flag<-1
 
	Mientras flag=1 Hacer
		Escribir "Ingrese sueldo del trabajador:"
		Leer sueldo
		Escribir "Anios en la empresa:"
		Leer years
 
		Si sueldo=0 Entonces
			flag <- 0
		SiNo
			si sueldo<450000 y years>=10 Entonces
				aumento <- (sueldo*0.20)
				total <- sueldo+aumento
				Escribir "Sueldo total: ",total
			FinSi
 
			Si sueldo<450000 y years<10 Entonces
				aumento <- (sueldo*0.05)
				total <- sueldo+ aumento
				Escribir "Sueldo total: ",total
			Fin Si
		Fin Si
 
	Fin Mientras
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar