ASP.NET - ASP 1.4322 running in IIS.8.5

 
Vista:

ASP 1.4322 running in IIS.8.5

Publicado por Maria (2 intervenciones) el 16/05/2020 23:37:23
Hola,

Tengo una aplicacion corriendo en un Windows Server 2003 Service Pack 2, IIS 6.0 y ASP 1.4322.
La aplicacion hace llamados a los siguientes objetos:
n la aplicacion que tenemos corriendo creamos los siguientes objetos:

1
2
3
4
5
6
7
Server.Createobject("wscript.shell")
 
Server.CreateObject("ADODB.Command")
 
Server.CreateObject("Scripting.Dictionary")
 
Server.CreateObject("Scripting.FileSystemObject")

La base de datos es un Oracle 8i y corre en un Solaris 8.
Hemos pasado la aplicadion a un Windows Server 2012 R2 IIS 8.5 y la aplccacion funcionan bien todos los objetos menos los de wscript.shell. ya que no conseguimos hace una llamada a wshell.run(unixcomand,0,true)
Tiene mapeada por nfs de la maquina unix y vemos que se crean los ficheros, pero la ejecucion de los comandos no la hace.
El unixcommand lo hacemos de esta manera "cmd.exe /cd start plink -ssh unixmachine" no conseguimos que ejecute nada ni siquiera un calc.exe en el localhost , con lo que es mas preocupante.

Hay alguna forma de arreglar lo de wshell.run? otra alternativa para ejecutar comandos a otra maquina desde la pagina ASP. Algun setting del IIS, permiso o ajustes en el registro?

Saludos y gracias,

Maria
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 90
Plata
Ha mantenido su posición en ASP.NET (en relación al último mes)
Gráfica de ASP.NET

ASP 1.4322 running in IIS.8.5

Publicado por Cesar (35 intervenciones) el 20/05/2020 23:58:02
Hola.

Al decir ASP "1.4322", deduzco que te refieres a ASP .Net 1.1.4322 (es decir ASP .Net 1.1).

Si es asi, no uses wscript.shell, para realizar conexion SSH.

Hay decenas de librerias .Net, para realizar conexiones SSH, y ejecutar comandos nativos de Unix/Linux (yo utilizo SSH .Net).

Por otro lado. Esa version es bastante antigua (es del 2003, es decir, hace 17 años).

¿Porque no la actualizas a una version mas reciente de .Net?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

ASP 1.4322 running in IIS.8.5

Publicado por Maria (2 intervenciones) el 21/05/2020 16:40:26
Gracias,
Si lo hemos pensado pero no he encontrado informacion de como actualizar de ASP .net 1.1432 a 2.0
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar