Access - Código Vb en informe que no me funciona

 
Vista:
Imágen de perfil de Salvador Parreño
Val: 88
Bronce
Ha disminuido su posición en 2 puestos en Access (en relación al último mes)
Gráfica de Access

Código Vb en informe que no me funciona

Publicado por Salvador Parreño (92 intervenciones) el 06/06/2015 11:14:08
En un infor tengo dos campos que quiero que cumplan la condición de que si uno es igual a cero, la etiqueta no sea visible. He puesto este código al cangar el informe y no me funciona.
1
2
3
4
5
6
7
Private Sub Report_Load()
If Me.media.Value = 0 Then
Me.Etisuma.Visible = False
Else
Me.Etisuma.Visible = True
End If
End Sub

Aguien me puede decir que es lo que hago mal?

Muchas gracias

Salva
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil

Código Vb en informe que no me funciona

Publicado por GOOO (46 intervenciones) el 06/06/2015 16:44:03
Hola salvador buen dia.

No sabria decirte con exactitud,
pero en algunas casos depende de donde estén los controles a los que aplicas en evento es más efectivo
donde dice: Al dar formato, dependiendo si es un encabezado de grupo, en la sección de detalle, o pie etc.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Código Vb en informe que no me funciona

Publicado por antperlop (1 intervención) el 06/06/2015 19:10:30
Tienes que ponerlo en "Al dar formato"
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Código Vb en informe que no me funciona

Publicado por jose (801 intervenciones) el 08/06/2015 13:11:51
en el evento al imprimir bien sea de cabecera, detalle o pie del informe
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de douglas
Val: 546
Plata
Ha mantenido su posición en Access (en relación al último mes)
Gráfica de Access

Código Vb en informe que no me funciona

Publicado por douglas (280 intervenciones) el 09/06/2015 01:44:12
Pruébalo así

Private Sub Report_Current()

If [Me.media].Value = 0 Then
Me![Etisuma].Visible = False

Else

Me![Etisuma].Visible = True

End If
End Sub
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar