Access - Silnm() no me evalúa bien

   
Vista:

Silnm() no me evalúa bien

Publicado por mario (3 intervenciones) el 26/07/2017 19:50:28
Hola a todos.

Estoy intentado crear una condición sliim en un cuadro de texto de Access y no se que hago mal, ya que lo he comprobado por partes y no me evalúa bien.

Lo que inserto es:

=SiInm([Texto209]>[Texto205];[Texto208];'Sin pérdidas')

En el mismo formulario tengo [Texto205], [Texto208 y [Texto209].

El caso es que al ejecutar la base de datos no me hace bien la condición y no se por qué.

En la foto se ven los valores de cada cuadro de texto y el valor final ("Pérdidas") de la condición:

1

Si (123>95,55 ; =23,44 ; 'Sin pérdidas')
Al ser verdadero debería dar 23,44 pero da 'Sin pérdidas'

Muchas gracias por su ayuda.

Un saludo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antonio

Silnm() no me evalúa bien

Publicado por Antonio (145 intervenciones) el 26/07/2017 20:25:07
En que momento activas el Silnm() ?'

al dar click a un boton??

intenta cambiar las ; por ,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Silnm() no me evalúa bien

Publicado por mario (3 intervenciones) el 26/07/2017 20:29:06
Al cargar el formulario.

Lo he usado otras veces con otras condiciones y nunca me había dado este problema.

Ya he probado con , pero me da error. Tiene que ser con ;

Muchas gracias por tu comentario.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antonio

Silnm() no me evalúa bien

Publicado por Antonio (145 intervenciones) el 26/07/2017 21:23:45
Ok cambia de evento, al activar.

prueba y me dices.

Si quieres mandame tu base y te ayudo

acuellarruiz@outlook.com
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Silnm() no me evalúa bien

Publicado por mario (3 intervenciones) el 26/07/2017 21:35:52
En vez de hacerlo en SQL lo he intentado hacer en código y el problema que me da es que no encuentra el campo [Texto205].

[Texto205] lo saco directamente de una tabla en función de una selección en un cuadro combinado.

En el código me da el error 2465: Microsoft Access no encuentra el campo '|1' al que se hace referencia en la expresión.

Muchísimas gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antonio

Silnm() no me evalúa bien

Publicado por Antonio (145 intervenciones) el 26/07/2017 21:50:57
Revisa el campo el nombre, talves tienes otro nombre en ese campo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar