Access - problemas con"Medio([campo],x,x]"

 
Vista:

problemas con"Medio([campo],x,x]"

Publicado por Claudio Senel (3 intervenciones) el 13/03/2006 15:58:49
Hola

tengo un problema con un campo texto que lo importo desde una tabla tps en formato texto, el campo pta la siguiente forma Ej "200201 1", el primero de enero del 2002 yo queiro dar vuelta la fecha con las funciones Izq,derecha y medio pero al separar el mes Medio([fecha],5,2) me muestra "01 1", es decir muestra el espacio y el dia como si fueran parte del mes, intente reemplazar el espacio con un 0 pero igual no puedo separar solo el mes, si alguien me puede ayudar gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:problemas con

Publicado por 2pl (775 intervenciones) el 13/03/2006 16:21:48
FECHA=FORMAT(DER[CAMPO];2);"00")&MID([CAMPO];5;2)&IZQ([CAMPO];4)
FECHA tendria el valor 01012002
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problemas con

Publicado por Claudio Senel (3 intervenciones) el 13/03/2006 16:55:13
Hola Gracias por tu pronta respuesta, sabes probe lo que tu me indicaste y me pta el siguiente resultado 0905 92005, es decir me vuelve arepetir el dia, si te fijas los primeros 4 digitos estan bien dia y luego el mes pero despues me vuelve a mostrar el dia con el espacio al medio y al final los ultimos 4 digitos con el año corectamente, es como si el mes, en este caso 05 y el día 9 estubieran juntos, como sifueran un solo digito, esto me pasa en todos los campos no colo en aquellos en que el "0" estaba ausente, eso del "0"quedo bien el cero se agrera sin problemas, el drama es lo otro, que no logro separar el mes del dia.

ojalá puedas ayudarme, saludos y muchas gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problemas con

Publicado por 2pl (775 intervenciones) el 13/03/2006 17:05:43
Si quieres me mandas la BD indicandome la consulta o el campo ese.Lo miro y te contesto. Aqui lo he probado y funciona correctamente.
Mi dirección antperlop@ono.com
Saludos desde Cádiz
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problemas con

Publicado por Cladio Senel (3 intervenciones) el 13/03/2006 17:32:29
ok
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar