Crystal Report - postgreSQL + aspx

 
Vista:
sin imagen de perfil

postgreSQL + aspx

Publicado por margarito (2 intervenciones) el 05/01/2017 18:53:23
hola, tengo un problema al conectar a una base de datos de postgreSQL. El código que utilizo es el siguiente:

el error que me arroja es

No se pudo abrir la conexión. No se pudo abrir la conexión. Reporte 11932_15256_{46172343-B640-4DA8-A79A-4664297B5CC0}.rpt

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
var crystalReport = new ReportDocument();
        crystalReport.Load(Server.MapPath(plantillaReporte));
 
        ConnectionInfo conn = new ConnectionInfo
        {
            ServerName = "Driver={PostgreSQL UNICODE};Server=123.123.123.123;Port=5432;",
            DatabaseName = "base_datos",
            UserID = "usuario",
            Password = "password",
            Type = ConnectionInfoType.Query,
            IntegratedSecurity = false,
        };
 
        foreach (CrystalDecisions.CrystalReports.Engine.Table tabla in crystalReport.Database.Tables)
        {
            TableLogOnInfo tablainfo = tabla.LogOnInfo;
            tablainfo.ConnectionInfo = conn;
            tabla.ApplyLogOnInfo(tablainfo);
        }
 
        var valor = Int32.Parse(LigValores[1]);
        crystalReport.SetParameterValue("param1", valor);
        valor = Int32.Parse(LigValores[2]);
        crystalReport.SetParameterValue("param2", valor);
        valor = Int32.Parse(LigValores[3]);
        crystalReport.SetParameterValue("param3", valor);
 
        ReporteVisor.ReportSource = crystalReport;
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil

postgreSQL + aspx

Publicado por Yamil Bracho (1 intervención) el 05/01/2017 18:57:42
Prueba haciendo la conexion via ODBC.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil

postgreSQL + aspx

Publicado por margarito (2 intervenciones) el 05/01/2017 20:08:22
desde la aplicación del crystal reports puedo hacer una previsualización de mi reporte.

pero si trato de hacer la previsualización desde visual studio del reporte me arroja el error que se muestra en la imagen.

no se si algún error de licencia, o algo así. O si necesito hacer alguna configuración extra.

imagen
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar