Dev - C++ - Instalar SFML en Ubuntu 16.04

 
Vista:
Imágen de perfil de Jean Pierre
Val: 169
Ha mantenido su posición en Dev - C++ (en relación al último mes)
Gráfica de Dev - C++

Instalar SFML en Ubuntu 16.04

Publicado por Jean Pierre (45 intervenciones) el 20/10/2018 17:31:45
Cuando instalo el SFML desde la consola se me instala con una version muy antigua

El comando que uso es
1
sudo apt-get install libsfml-dev
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de info
Val: 9
Ha aumentado su posición en 5 puestos en Dev - C++ (en relación al último mes)
Gráfica de Dev - C++

Instalar SFML en Ubuntu 16.04

Publicado por info (2 intervenciones) el 20/10/2018 22:01:36
Prueba a actualizar el respositorio...

1
sudo apt-get update

aunque puede ser que el repositorio que estes utilizando no se actualice!!! que distribución y repositorio estas utilizando?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Jean Pierre
Val: 169
Ha mantenido su posición en Dev - C++ (en relación al último mes)
Gráfica de Dev - C++

Instalar SFML en Ubuntu 16.04

Publicado por Jean Pierre (45 intervenciones) el 20/10/2018 22:12:43
No eso no funciona, uso ubuntu 16.04

Aunque he visto que la ultima version de SFML parece que solo se instala compilandolo para ubuntu 16.04 porque yo tenia ubuntu 18.04 y se instala desde la consola la ultima version
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil

Instalar SFML en Ubuntu 16.04

Publicado por juanki (73 intervenciones) el 21/10/2018 10:28:36
Hola

Supongo que será por que estás usando una versión muy antigua de Ubuntu, yo tengo la última y se me instala la versión más reciente de SFML.

Si no puedes actualizar ubuntu tendrás que descargarte SFML de su web y hacer la instalación "a mano", no sé si te tocará compilar SFML.

Repasa la documentación de su web, que seguro que hay información sobre cómo hacerlo.

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Jean Pierre
Val: 169
Ha mantenido su posición en Dev - C++ (en relación al último mes)
Gráfica de Dev - C++

Instalar SFML en Ubuntu 16.04

Publicado por Jean Pierre (45 intervenciones) el 21/10/2018 12:50:31
Elimine ubuntu 18.04 porque me estaba generando mal los ejecutables, cuando compilaba los ejecutables decian que eran de tipo shared library y no los dejaba abrir, yo creo que es porque hace poco salio

Pero igual tocara volver a instalarlo haber que pasa
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil

Instalar SFML en Ubuntu 16.04

Publicado por juanki (73 intervenciones) el 21/10/2018 14:09:29
¿Cómo? Cosa rara!!

No sé como creas los proyectos y compilas, si usas algún IDE o qué, pero igual escogías el tipo de proyecto librería o algo, es muy raro!!

En todo caso no sería problema de la versión de ubuntu, si no de cómo compilas el proyecto o el IDE que uses.

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar