Dev - C++ - buenas me pueden revisar este codigo

 
Vista:
sin imagen de perfil
Val: 34
Ha disminuido su posición en 2 puestos en Dev - C++ (en relación al último mes)
Gráfica de Dev - C++

buenas me pueden revisar este codigo

Publicado por carlos (35 intervenciones) el 11/04/2019 00:03:47
Desarrolle una solución que permita almacenar la cédula, nro. de mesa y centro de votación para un total de 3500 votantes, ya que con frecuencia se requiere consultar si algún votante aparece en la lista o cambiar el centro de votación.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
Inicio
 
  Registro t_vot
 
    Inicio
 
      Alfanumérico cedula, centro
 
      Entero    #mesa
 
    Fin
 
 
 
  Alfanumérico Micedula,existe,Micentro,Mimesa
 
  t_vot  votantes[3500]
 
  Entero i,opción
 
 
 
  Repita desde i=1  hasta  i=3500  incremento 1
 
    Inicio
 
      Escribir “Deme Nro. de Cédula,  Nro. de Centro y Nro. de Mesa”
 
      Leer votantes[i
 
].cedula, votantes[i].centro, votantes[i].#mesa
 
    Fin
 
 
 
  Escribir “1. CONSULTAR,  2. MODIFICAR,  3. SALIR”
 
  Escribir “Elija su opcion”
 
  Leer opción
 
 
 
  Mientras opción ≠ 3
 
    Si opción = 1  entonces  àSi se elige consultar si un votante aparece en lista
 
      Escribir “Deme la cédula”
 
      Leer Micedula
 
      Existe = No
 
      i =1
 
 
 
      Mientras i <= 3500  y  existe = No
 
        si votantes[i].cedula = Micedula
 
            Existe = Si
 
        sino
 
            i = i + 1
 
        fin si
 
      fin mientras
 
 
 
      si existe = Si
 
Escribir “Votará en el centro de votación:, votantes[i].centro, “ y en la    mesa número:, votantes[i].#mesa
 
       Sino
 
            Escribir “Votante No Aparece en Lista”
 
       Fin si
 
    fin si  à fin de la opción 1
 
 
 
    Si opción = 2  entonces  àmodificar el centro de un votante existente
 
      Escribir “Deme la cédula”
 
      Leer Micedula
 
      Existe = No
 
      i =1
 
      Mientras i <= 3500  y  existe = No
 
        si votantes[i].cedula = Micedula
 
            Existe = Si
 
            Escribir “Deme el nro. del nuevo centro y del nro. de mesa”
 
            Leer Micentro, Mimesa
 
            votantes[i].centro = Micentro
 
            votantes[i].#mesa = Mimesa
 
        sino
 
            i = i+1
 
        Fin si
 
      Fin mientras
 
    Fin si  àfin de opción 2
 
    Si existe = No entonces
 
      Escribir “El votante No Existe en Lista”
 
    Fin si
 
 
 
    Escribir “1. CONSULTAR, 2. MODIFICAR,  3. SALIR ”
 
    Escribir “Elija su opción”
 
    Leer opción
 
 
 
  Fin mientras   àfin del mientras opción ≠ 3
 
Fin       àdel algoritmo
 
 //le puse cocos votantes para hacer pruebas
 
#include<iostream>
 
using namespace std;
 
 
 
struct votante{
 
 
	int cedula;
 
	int centro;
 
	int mesa;
 
 
};votante v[4];
 
struct centro{
 
 
int micedula,micentro,mimesa;
 
 
};centro ce[3];
 
int i;
 
int main()
 
{
 
	int op;
 
	for(  i=1; i<3; i++)
 
	{
 
	cout<<"digite cedulas ";
 
	cin>>v[i].cedula;
 
 cout<<"cedula"<<v[i].cedula<<endl;
 
}
 
int k;
 
for( k=0; k<4 ; k++)
 
{
 
	cout<<"digite el cetros"<<endl;
 
	cin>>v[k].centro;
 
}
 
int j;
 
for( j=0; j<9 ; j++)
 
{
 
	cout<<"digite la mesa";
 
	cin>>v[j].mesa;
 
}
 
 	cout<<"[1] consultar"<<endl;
 
 	cout<<"[2] modificar"<<endl;
 
 	cout<<"[3] salir"<<endl;
 
 	cout<<"[4]elijir una opcion";
 
 	cin>>op;
 
switch(op)
 
{
 
 
 
case 1:
 
cout<<"digite la consulta";
 
cin>>v[i].cedula;
 
v[i].cedula=ce[i].micedula;
 
i=1;
 
while(i<=3)
 
{ ce[i].micedula=0;
 
if(v[i].cedula=ce[i].micedula)
 
v[i].cedula=ce[i].micedula;
 
else{
 
	i=i+1;
 
}
 
}
 
if(v[i].cedula=ce[i].micedula)
 
{
 
 
 
cout<<"votara en el centro"<<v[i].centro<<"y en la mesa numero"<<v[j].mesa;
 
}
 
else{
 
	cout<<"de lo contrario no se encuentra en la lista";
 
	cout<<"digite la cedula";
 
	cin>>ce[i].micedula;
 
ce[i].micedula=0;
 
}
 
break;
 
     case 2:
 
	cout<<"modificar centro de votacion"<<endl;
 
	cout<<"digite la cedula";
 
	cin>>ce[j].micedula;
 
	ce[i].micedula=0;
 
	i=1;
 
	while(i<=3)
 
	ce[i].micedula=0;
 
	if(v[i].cedula=ce[i].micedula)
 
	{
 
		ce[i].micedula=1;
 
		cout<<"digite el numero del nuevo centro y de nueva mesa";
 
		cin>>v[k].centro,ce[j].mimesa;
 
		v[j].centro=ce[j].micentro;
 
		v[j].mesa=ce[j].mimesa;
 
	}
 
	else{
 
		i=i+1;
 
	}
 
	   v[i].cedula=0;
 
	   cout<<"el votante no  existe en lista";
 
 
 break;
 
}
 
 return 0;
 
}
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder