Excel - Como puedo crear esta condición

 
Vista:
sin imagen de perfil

Como puedo crear esta condición

Publicado por Serydarian (3 intervenciones) el 30/03/2017 00:00:19
Necesito conocer como resolver estas condiciones


Si “A” vende y “1” vende, ambos reciben 10 puntos.
• Si “A” compra y “1” compra, ambos pierden 10 puntos.
• Si “A” compra y “1” vende, “A” gana 20 y “1” pierde 20.
• Si “A” vende y “1” compra, “A” pierde 20 y “1” gana 20.

asumiendo que A y 1 son valores reales de celdas.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 82
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Como puedo crear esta condición

Publicado por José Luis (43 intervenciones) el 30/03/2017 02:23:43
Hola,

Puedes hacerlo con buscarv( o con si(

SI utilizas SI( deben ser 3 condiciones , la formula se debe copiar en 2 columnas
1.- celda1="vende" y celda2="vende" valor para columna1 = 10, columna2 = 10
2.- celda1="compra" y celda2="compra" valor para columna1 = -10, columna2 = .10
3.- celda1="compra" y celda2="vende" valor para columna1= 20, columna2 = -20
por default celda=vende y celda2=compra valor para columna1=-20, columna2=20

Sé que es problematico debuguear mas de 3 si( anidados y adicionalmente con la condicion Y(


formula
1
2
3
4
Formula para columna1
=SI(Y(A2="COMPRA",B2="COMPRA"),10,SI(Y(A2="VENDE",B2="VENDE"),-10,SI(Y(A2="COMPRA",B2="VENDE"),20,-20)))
Formula para columna2
=SI(Y(A2="COMPRA",B2="COMPRA"),10,SI(Y(A2="VENDE",B2="VENDE"),-10,SI(Y(A2="COMPRA",B2="VENDE"),-20,20)))

Saludos
José Luis
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil

Como puedo crear esta condición

Publicado por hovannes (3 intervenciones) el 30/03/2017 18:21:28
Buenas tardes, Muchas gracias por la información
Pero al colocar la formula me da un error, y no logro dar cual es problema.

Agradecido de ante mano por todo el apoyo


cap0001
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 82
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Como puedo crear esta condición

Publicado por José Luis (43 intervenciones) el 31/03/2017 00:50:12
Te adjunto el archivo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil

Como puedo crear esta condición

Publicado por hovannes (3 intervenciones) el 31/03/2017 13:55:09
Muchas gracias por la información...

Es genial este sitios de consulta, el mejor de todos. Muchísimas garcías
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar