Excel - SI y BUSCARV...Anidadas

   
Vista:

SI y BUSCARV...Anidadas

Publicado por David (5 intervenciones) el 12/06/2017 00:42:44
Tengo escrita una formula que funciona perfectamente: =SI(B$11=1;(BUSCARV(B26;CASO1!$A$1:$B$5;2;2)))

Dada una condición en la celda B11...me copia los datos de 5 celdas que están en otra hoja llamada CASO1. Quiero anidar mas condiciones porque tengo más hojas y me funciona esto:

=SI(B$11=1;(BUSCARV(B26;CASO1!$A$1:$B$5;2;2));SI(B$12=1;(BUSCARV(B26;CASO2!$A$1:$B5;2;2))))

Me parece una barbaridad porque tendré que poner por lo menos 10 condiciones...

Tampoco se si estoy llevando esto por el planteamineto correcto. ¿Alguna ayuda? Graciasssss
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com

SI y BUSCARV...Anidadas

Publicado por wordexperto.com (1370 intervenciones) el 12/06/2017 08:03:08
Efectivamente, es una locura. No se deben anidar más de tres si. Debes añadir un rango auxiliar con los valores posibles y ahí utilizar un único buscarv.
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de Andres Leonardo

SI y BUSCARV...Anidadas

Publicado por Andres Leonardo (894 intervenciones) el 12/06/2017 15:56:52
creo que deberias poner lo que tienes para poderte ayudar mejor .. por lo pronto coincidimos con PEPE Imposible anidar mas de 3

**Yo no lo hago ni con 2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de wordexperto.com

SI y BUSCARV...Anidadas

Publicado por wordexperto.com (1370 intervenciones) el 12/06/2017 18:49:40
Otro detalle que había pasado desapercibido, hasta ahora, es el número de hojas.
En la mayoría de las ocasiones, solo son necesarias dos hojas. Una con los datos estructurados como base de datos, con todas las clumnas que necesites. Puedes añadir una nueva columna con el criterio que usas para la división en hojas. Y otra para los informes con tablas dinámicas. Ninguna fórmula en las dos hojas y una estructura de libro para toda la vida.
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

SI y BUSCARV...Anidadas

Publicado por David (5 intervenciones) el 13/06/2017 10:26:52
Gracias por responder. Voy a elaborar un pequeño ejemplo de lo que quiero y voy a intentar estructurar la base de datos en una sola hoja.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

SI y BUSCARV...Anidadas

Publicado por David (5 intervenciones) el 20/06/2017 01:03:18
Esto es un pequeño ejemplo de como lo estaba planteando, sabiendo que no es el camino anidar tantas condiciones. Decía EXPERTO que por que juntaba las hojas en un solo cuadrante; Estas hojas son en realidad "fichas" y quería editarlas por separado y volcarlas a un directorio y así poder repartir el trbajo entre más gente porque fichas puede haber más de 100.....y claro, no voy a anidar tanto.

Una ayudita Please. Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com

SI y BUSCARV...Anidadas

Publicado por wordexperto.com (1370 intervenciones) el 20/06/2017 11:05:40
Hola David:
Necesitas una celda auxiliar que te encuentre la fila en la que está el uno. Esa fila será el número de la hoja CASO que ya usarás en la fórmula de I10 con buscarv.
Fórmula para la celda auxiliar: =COINCIDIR(1;B11:B18;0)
Fórmula en la columna I: =BUSCARV(H10;INDIRECTO("CASO" &E11&"!A1:B43");2;0)
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

SI y BUSCARV...Anidadas

Publicado por David (5 intervenciones) el 21/06/2017 00:02:38
Que solución más elegantes. Ya tengo Trabajo por delante bastante. Gracias equipo! Tengo una duda más que se me pasó. Voy a volver a elaborar y ya te cuento. Muchisimas pero que muchisimas gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar