Excel - macro para buscar en una tabla un contenido

 
Vista:

macro para buscar en una tabla un contenido

Publicado por Giuliano (1 intervención) el 12/09/2017 21:17:24
Tengo una lista de productos que se suman los subtotales y se llega a un total.

Coloque un combo en una celda cuyas opciones son los nombres de clientes que aparecen en otra hoja, al lado de los nombres en dicha hoja esta el total que deben.

Entonces al tener un ticket quiero buscar el nombre seleccionado del combo en la lista de la otra hoja para sumar el total a lo que debe el cliente. ¿Como puedo hacerlo? Les adjunto el fichero
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.154
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

macro para buscar en una tabla un contenido

Publicado por Antoni Masana (1459 intervenciones) el 13/09/2017 07:33:02
No entiendo lo que estás haciendo.
De lo que si entiendo: debes asignarle una macro al combo para que cuando seleccione realice la búsqueda.

Por otro lado esta rutina esta mal. Repasemos

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Sub Borrar()
    Dim cliente As String
    Dim ticket As Double
 
    cliente = Hoja2.Range("C3").Value
    If cliente = "" Then
       MsgBox "SELECCIONE CLIENTE"
    Else
       ticket = Hoja2.Range("E28").Value
 
       Sheets("TICKET").Select
       Set c = Range("B3")
       Dim saldoactual As Double
       saldoactual = Range("C3").Value
       Do
          nuevosaldo = saldoactual + ticket
          Set c = c.Offset(1, 0)
       Loop While c.Value = cliente
    End If
    Range("A5:D25").ClearContents
End Sub

Las líneas 5 y 9 no hagas referencia a Hoja2. es mejor Sheets("TICKET")..

En la línea 13 defines la variable saldoactual como número Double y en la línea 14 le asignas el nombre del cliente .

La líneas de la 5 a la 18 es todo un desproposito, Asignas a la variable nuevosaldo, ¿Donde esta definida? ¿Que utilidad tiene?, el contenido de saldoactual, que ya he comentado en el parafo anterior, más el valor de ticket que es CERO porque no se le asigna valor alguno.

Y si borra para que tanto rollo.

Otra cuestión en la columna E donde haces la suma es mejor así

1
=SI(Y(ESNUMERO(A5);ESNUMERO(D5));SUMA(A5*D5);"")

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar