Excel - Eliminar número premiado de la lista tras realizar sorteo

   
Vista:
Imágen de perfil de Aprendiz de excel

Eliminar número premiado de la lista tras realizar sorteo

Publicado por Aprendiz de excel (2 intervenciones) el 14/11/2017 19:23:37
Hola amigos:

Tengo casi listo un programa para un sorteo de regalos que hace mi empresa en la comida de navidad.

Lo único que me falta es una macro que haga que una vez que ha salido cada número lo elimine de la lista para que lógicamente no se repita.

En la comida habrá unas 150 personas y cada una llevará 10 boletos.

El programa es bastante más extenso que el que envío pero para lo que necesito, creo que es suficiente.

Espero me ayudéis a terminarlo

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana

Eliminar número premiado de la lista tras realizar sorteo

Publicado por Antoni Masana (691 intervenciones) el 22/11/2017 11:21:38
Ya lo tengo, Cuando sale un numero lo borra de la columna C y si la celda ya está vacía vuelve a realizar el sorteo hasta conseguir un número:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Sub Aleatorio()
    ActiveSheet.Unprotect:  Sheets("SORTEO").Select
    ActiveSheet.Unprotect:  Range("A1").Select
 
    Application.Calculation = xlCalculationAutomatic
    For X = 1 To 600
       Selection.ClearContents
    Next
    Application.Calculation = xlCalculationManual
 
    Codi = "C" & Range("N31") + 1
    If Sheets("LISTA").Range(Codi) = "" Then
       Call Aleatorio
    Else
       Sheets("LISTA").Range(Codi) = ""
    End If
End Sub

Cambia la fórmula de la celda G14 por esta

1
=SI.ERROR(BUSCAR(E14;LISTA!C2:C90;LISTA!D2:D90);"")


Saludos.
\\/_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Eliminar número premiado de la lista tras realizar sorteo

Publicado por APRENDIZ DE EXCEL (2 intervenciones) el 23/11/2017 11:02:27
Gracias Antoni, me has sido de muchísima ayuda. por fin he podido terminarlo
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad