Excel - Formula si condicional

   
Vista:

Formula si condicional

Publicado por JUAN (1 intervención) el 24/11/2017 03:09:45
Buenaas noches, se me queman las pestañas.
cuando uso la formula =SI(I4=F4;F1;SI(I4=D4;D1;SI(I4=B4;B1)))
Esto es, si i4 es igual a f4 que me muestre f1, pero si i4 es = a d4 que me muestre d1, pero si i4 es = a b4 que me muestre b1.
Hasta ahi todo bien, el tema es que cuando hago copy/paste para copiar la formula en celdas descendentes me cambia el valor de F1,D1,B1 que son los que necesito q queden siempre fijos.
Alguna ayuda??

Es una tabla de precios de proveedores, de la cual lo que debe quedar fijo es el nombre de cada unno de ellos, i4 es el valor mas bajo elegido de los 3 proveedores

prov1 prov2 prov3
U$D $ U$D $ U$D $

Producto 114 2040,6 105 1903,65 105,00 1903,65 105
producto 130 2327 140,00 2497 0 0 130


se entiende?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana

Formula si condicional

Publicado por Antoni Masana (829 intervenciones) el 24/11/2017 06:19:20
Primera cuestión de la fórmula:

I4 puede tener 3 valores que son F4 - D4 - B4 y cuando no tenga ninguno de ellos ¿Que pasa? ver parte subrayada

Segunda cuestión Referencias absolutas:

1
=SI(I4=F4 ; $F$1 ; SI(I4=D4 ; $D$1 ; SI(I4=B4 ; $B$1 ; "" )))

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad